Close rear object lines are displayed over front objects in viewport "Rendered" mode

(Petr Benes) #1


I am using Rhino 5 SR5 (5.5.30717.16015, 17. 7. 2013) 64-bit running on Windows 8.

I would ask you for advice on how or where to set the parameters affecting visibility of rear objects in front of front objects in viewport (see img 3). We use “Rendered” mode with surface edges ON (or another mode based on Technical) for making instruction sheets. We printscreen the viewport and use the picture further.
We have the problems with objects which are close behind front objects (see img 1 or 3). They are still visible like ghosts depending on camera distance or focus (see img 2) and we need to select them and hide them or make retouches in other software. But projects are realy hudge and it takes lots of time to hide or unhide objects or retouch them elsewhere.

Is there any simple solution for that? It depends on what? We use “Small Objects - Millimeters” / “Small Objects - Inches” file templates and we tried to play with tolerances in settings too, but no success.
How to make close rear object lines NOT visible over front object in viewport “Rendered” mode or any display mode?

Thanks for help.

Img 1)

Img 2)

Img 3)

(Pascal Golay) #2

Hello- try TestZBiasFactor > Less. Does that do anything good?


(Petr Benes) #3

Hello Pascal,

thanks for this hiden command. If set somewhere around 0.00000000001 in some scenes it can help while zooming in or out a camera a bit (the artefacts flickers while zooming in or out) You can find camera position, where it is not visible, but it is not 100% successful.

What is it about? Is it technically possible to make rear objects not to be visible over the front objects?


(Brian James) #4

Hi Petr,

If you can send one of these models in to I’ll make sure it gets added to a report for improving this display artifact. It would be ideal to not have the test command at all. I have found that adjusting the thickness of the surface edges in the display mode can fix this too.