Clone Element creates lists

I would assume that when I input two elements and two locations that are not branches of a tree I would get two items on the output.
However, Clone Element component behaves as if the Location input is grafted. Is this standard behaviour or a bug?

Rhino: 7.21.22208.13001 (Rhino 7)
Revit: 2023.0.1 (23.0.10.18)
CLR: 4.0.30319.42000 (4.8.4515.0)
OS: Microsoft Windows NT 10.0.19044.0

Its acting as if you would like to clone each element twice, this is atypical GH behavior where these would be [0]-[0], [1]-[1]matched instead of [0]-[0,1] , [1]-[0,1]. Thanks for reporting.

To clone each one once you would graft both inputs.

Yea, I am using it with both inputs grafted at the moment. This morning I tried to casually place 400 elements at 400 locations and my computer melted…

Also, not sure if it is somehow specific to my inputs, but when I run the component for the first time - everything is ok but if I try to update the locations shift randomly.
P.S. - I am placing Vray Chaos Cosmos people if that matters.

Can these Vray Elements be placed with the Add Component Location then changed via Element Location?

I can’t test it right now. I will check as soon as I am able.
But now I manage to update by using delete component before I update once, then disable the delete component and update which results in properly placed elements (people).