Clipping Planes off in display mode

In an attempt to deal with the current state of the Clipping Planes in the WIP (in this case trying to get it to render clipped edges as I want), I tried to disable showing those in my default work display mode. Reasoning is that I cannot turn off the layer with the clipping planes on because then I don’t get edges so I will have the layer on and locked but disable the display of them in my regular display mode.

I have 2 clipping planes in my model but when disabling the display of them in Options > View > Display Modes > [my mode] > Visibility > Show clipping planes, only the one that is active in that particular viewport is hidden. I would expect all to be hidden.