Clipping planes not working correctly

Hi, In Rhino 7, build Version 7 (7.4.21040.13001, 2021-02-09) the clipping planes don’t behave as in previous versions. I’ll create several clipping planes in several views, rotate them or move them to where I want and I’ll turn them off or on, one by one or several at a time. But not in version 7. In 7, or at least the version I point out above, when I have created several of them and use the properties panel/clipping plane properties and select just one, and then select lets say top viewport for the clipping plane to be active, all of the clipping planes become active not just the one you selected. Then select another clipping plane and you will see that it is indicating that it too is active in the top viewport. Deselect that viewport and all are no longer active. This was never the case with earlier versions!
Try this to see what I mean. Make a sphere in any viewport and then make two clipping planes one in the front viewport and one in the right lets say. Then go to the properties panel/clipping plane properties and select just one. Pick a viewport and see what it does. On my system, all the clipping planes are affected. Select the other clipping plane which you haven’t touched yet and it too will be active in that viewport and vice a versa.




Thank for your help.

Hello - I see this, thanks for the report.
RH-62866 ClippingPlane: Properties applied to all

-Pascal

I have the same problem for Rhino 7.4. Are there any fixes for this bug yet? I have changed to an older installation of Rhino 6 meanwhile.

There is a bug request, that’s all I know for now.

I thought they fixed it in Version 7 SR5 (7.5.21074.17001, 2021-03-15) which they did but with one caveat. If you create what I described in the original bug reporting, you will see there is one issue left. I created a sphere in the top viewport then created a clipping plane in the front viewport and the right viewport. Normally the way it used to be, whatever viewport you created the clipping plane, that viewport was automatically assigned that clipped view. When I did it, the front viewport automatically assigned the clipping to the top viewport, not the front.


When I created the a clipping plane in the right viewport, the behavior was what I expected. Oddly enough, I tried something different. I deleted the two planes and created two new ones. I got a completely different results. Then I created a new project while Rhino was still running, same thing, different results. The last attempt to see the behavior I tried was I shut down the app and restarted it, tried again, different results again. Here is the picture with just one clipping plane in the front viewport,
To me, this is very strange behavior!

Thanks for the heads-up, I’ll have a play with it here.
OK so far here in our latest, I’ll try 7.5
I cannot get this to do what you describe… Does it work as expected if you maximize the viewport?

-Pascal

Yes, when I maximized the viewport, then it worked. So I just tried this. I rebooted the computer, then launched Rhino and tried this experiment again. All 4 viewports are open. I created a sphere in the top VP at 0,0, on the default layer. Then while all the VP’s are still up, I changed to Layer 01, created a clipping plane in the front VP, This is what I got.

Hi - I can reproduce that here but it’s the expected behavior.

  • You have created your sphere in the Top viewport. The Top viewport is active.
  • You move your mouse to the Layers panel and change the current layer to Layer 01.
  • You run ClippingPlane and the Top viewport is still active.
  • You then move the mouse to the Front viewport - automatically making this one the active viewport.
  • You now place the clipping plane in the Front viewport.

So - this statement is not accurate. It’s whatever viewport that was active when the command was called that gets clipped. Not the viewport where the clipping plane is placed.
Rhino 6 shows the same behavior - and this is really handy when you have lots (“very lots”) of layouts with several details and you want to clip the view in one of those details. You start the command in a detail, move to model space and create the clipping plane in the perspective view.
-wim

Well I stand corrected! I’ve been using these items for a long time and I’ve never had this happen. Well in any case, thank you for your help. I try in the future to be more methodical in my approach.

1 Like