Clipping Planes not capping

This issue is about hidden clipping planes not being restored when a named view is restored.
(RH-29592 was commented to reflect gained insight on March 5th).

File to demonstrate the issue:
ClippingPlane Capping.3dm (890.5 KB)

Thanks for the file and extra info. I filed http://mcneel.myjetbrains.com/youtrack/issue/RH-35029 which shows the issue without the layer variable. It looks like named views aren’t taking note of the clipping plane state. I am seeing the cp turn off entirely when toggling named views but capping works fine once it’s enabled.

I also just filed http://mcneel.myjetbrains.com/youtrack/issue/RH-35030 which may be related… thumbnails for named views aren’t showing cp sections.

Hi Brian,
I downloaded that model and followed the instructions but was unable to reproduce the problem. Were you able to reproduce the issue with the model that I provide and the instructions that came with it?

I just looked again and now I can get what you see, I must have done something wrong the first time.
Filed http://mcneel.myjetbrains.com/youtrack/issue/RH-35031

If you continually toggle the v0 and v1 named views, you should see the clipping disappear entirely which is what I was trying to file in RH-35029

FWIW,

Clipping planes never cap any objects in the latest WIP - i.e. 2016-11-01.

Shall I make a new YT-issue or should we recycle RH-33562 or RH-34713?

Thanks, I reopened 34713.

Thank you, Brian!

RH-34713 is fixed in the latest WIP

I guess I disagree. I’m sure it’s all a question of how one defines that this is supposed to work but as per my comment in RH-34713 d.d. 2016-08-03 (permalink) it still doesn’t work when the CP is on a layer that is off.

Just to repeat this: I invoke clipped views by calling a named view that was saved with a clipping plane active. As long as the clipping plane is visible (i.e. not hidden or not on a layer that is off), this works as expected. When the CP is invisible (hidden or on a layer that is off), calling the named view that is clipped will still clip the view but not fill the cut.

Thanks @wim, I’ve reopened that issue again and reiterated your comment.

1 Like

RH-34713 is fixed (again!) in the latest WIP

Thanks!

In the attached, though, I have a few named views (v0 -> v4). When I type v1, v2, and then v0, I end up with a clipped view. v0 is unclipped though, and when I type v0 once more the view becomes unclipped. I suppose there is still something happening that is preventing the restoration of the correct view-clipping plane combination at once.

ClippingPlane.7z (602.1 KB)

Hi Brian,

Is that for the next WIP or the current one, I wasn’t sure?

Andy

Hi @brian

There are a few anomalies with clipping planes and the new update:

http://screencast-o-matic.com/watch/cDX0D0Q1I5

I’m just going to check my driver and update it…

OS Name Microsoft Windows 10 Pro
Version 10.0.14393 Build 14393
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name 2DCUBE
System Manufacturer ASUS
System Model All Series
System Type x64-based PC
System SKU All
Processor Intel® Core™ i7-5960X CPU @ 3.00GHz, 3001 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 0801, 27/11/2014
SMBIOS Version 2.8
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United Kingdom
Hardware Abstraction Layer Version = “10.0.14393.206”
Username 2DCUBE\2DCube
Time Zone GMT Standard Time
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.9 GB
Available Physical Memory 27.0 GB
Total Virtual Memory 32.1 GB
Available Virtual Memory 26.5 GB
Page File Space 200 MB
Page File C:\pagefile.sys
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware No
Hyper-V - Data Execution Protection Yes

@stevebaer,
I’m recycling this thread -
Clipping Planes won’t cap geometry again in the latest WIP (6.0.17087.9481, 2017-03-28).

Thanks, I reopened the bug

RH-34713 is fixed in the latest WIP

@stevebaer,
Note that in the latest WIP, the capping of the clipped geometry somehow is dependent on objects in the scene.

Clipped view - no caps:

[Actually, that shows a partial cap - the section on the far side of the vertical hole is actually capped - as seen in this close-up:

Showing more objects - the partially capped part is increasing in size:

Showing an external housing makes everything cap as it should:

[File uploaded to tech@mcneel.com]

@jeff I’m going to need your help on this one.

Ok…I’m wrapping up a YT item in an hour or so…then I’ll take a look at this. I have the file.