Clipping plane visibility

is there any way to make the clipping plane invisible in the viewport it is clipping? why do we want to look at everything with an X through it?

Hi Ryan- you can scale it, or move it- the plane is infinite regardless of the widget size or location. You can also hide it- setting up a special layer for these might be the most convenient


Hi Ryan,

For perpendicular places ClippingPlanes I’d agree, yet often I also use one to examine objects in a perspective view.
I can manipulate the ClippingPlane to show sections at various positions and orientations:

or smaller for better visibility


You can also toggle clipping plane visibility per display mode - in the display panel.

Just so we understand the use case when relating to boat design… It’s desirable to see the clipping plane in the plan and profile views to choose a section of the hull to view in the bodyplan (front? of boat i guess)… except in order to have the clipping plane go through the hull in the plan and profile view there seems to be no way to avoid looking through the X in the bodyplan.

I ended up making the planes really big so that the whole boat fits inside one of the plane quadrants then moving the gumball gizmo over so it’s still in the middle of the ship. Works but kinda hack. There is already functionality for checking off what model views and layouts are affected by the plane. Seems logical to be able to check off what views you want it visible in.

Ideally there would be a way to pull a single “live” section by using one plane… instead of having to use two clipping planes facing opposite ways that are very close together. Ive been using section tools to do that when I need to do something precise but it’s not interactive and it’s slow and obvisously produces a 2d drawing that needs to be measured then whatever changes reintegrated into 3d then sectioned again etc.

Or I guess you could clone the wireframe view mode (call it wireframe no clips or whatever) as mikolaj suggests and uncheck clips works 90% of the time unless you want to use longitudinal clips then would have to change view modes back.

not sure if you’ve solved this already, but placing the clipping plane in a separate layer and turning off that layer makes the plane invisible but keeps the clipping

1 Like