Clipping plane view slow

if:

  • the camera is on the clipped side of the plane navigation is slower
  • and “advanced GPU lighting” is turned OFF.

pretty strange as usually not using Advanced GPU gives me better speed on complex models, but as soon as a clipping plane is involved rotating the view is very sluggish… lagging behind the mouse cursor. a bit disturbing, because one needs to adopt display modes.

using latest rhino 5 sr and nvidia 361.43 on titan X

cheers
daniel

I’m not seeing this here with a few models I’ve tried. Same driver and a Titan black. Any chance you can upload a model to www.rhino3d.com/upload ? It’ll go to tech@mcneel.com by default which is fine, just say for Brian J and reference this forum thread.

The default Shaded mode is what I was using too which has adv GPU disabled. At a guess, this might have to do with the specific geometry or other display mode settings. Thanks for reporting.

Hi Brian,

I just uploaded a small file which already shows the problem, at least here on my machine.
To correct my last post a little, viewport rotation is in fact almost fluent if I look along the plane (so that it is hardly visible); once the cam gets more view of the clipping plane it gets a lot slower.
all only if advanced gpu lighting is turned off.
I know it is your policy anyway but please treat the file confidential .

thanks!
daniel

Thanks Daniel!

I replied via the support email… and filed a confidential bug report as I could reproduce it after rotating the clipping plane.

Hi Brian,

thanks for the update
glad I could help!

cheers,
d.