Clipping plane does not behave properly

As seen in the picture, clipping plane seems go crazy, when provided with more complex geometry than a box (literally)…


Can you please post your 3dm file?
I drew a box then twisted and bent it and the clipping plane worked fine.

sure thing! there you go

klein_surface.3dm (4.3 MB)

Looks fine here…

Please run SystemInfo and post the results here. Your system may be using a different set of code based on the available OpenGL version than what John is using.

interesting… here is the file

SystemInfo.txt (9.2 KB)

@stevebaer this might be something related to Rhino 6 for Mac wip no AA (doesn't use the better display adapter)

Two different GPUs reported…

I doubt it, I enable a different shader on ATI gpus since they perform terrible with translation shaders. This shader was just written and I probably don’t handle clipping planes correctly

Thanks; I’m able to repeat this bug on an ATI OpenGL driver here. We wrote a some special code to try and work with the ATI OpenGL drivers on Mac (which I know is the typical Mac nowadays) because they have been a bit problematic. This looks like another manifestation of the problem.

I’ve logged the bug at

If you’re willing to try, here is a brand new build that has my fix in it from last night.

This should be fixed in the latest RhinoWIP. Please give it a try on your AMD card and let us know if it still gives you trouble. Thanks again for reporting this.

Thank you guys for the effort - ClippingPlane seems to work fine in the new built!
Keep up the great work!

Greetings, Rudi

1 Like