Circles projected to surface some are part visible shaded view what fix?

Having projected circles to surface, some are not showing up fully, as I rotate perspective sometimes they improve.
I have two which despite being re-projected still seem to sit under the surface a fraction.

Its obviously a settings surface display thing going on, as technically they are on the surface.

What can I do to ensure they all show.

I have tried display line thicker and print preview but it hasnt worked.


Hi Steve,
The projected curve aligns perfectly with the surface and this is why the shader might not know which object it should show.
Use BringForward command to give priority to your curves. This will probably help.

Not aware of that so tried it, unfortunately the circles on the stbd side of the aircraft also now show when viewing port, though they are still on the stbd skin, I thought I was in x ray view or something.

As such thats no good really at all, as I am now seeing double !

Are there any shaded view settings to alter this ?

The whole point of the exercise was to do a visual of what was where and indicate dimensions but with circles fading in and out its not good.

Maybe I need to select all circles and lines and extrude them in one go a fraction of a mm both sides, or just outwards and this must see each item extruded perp to skin. How would that be done ?


What do you mean by “stbd” side? Can you share an image to show why BringForward is not helping?

I just quickly made a surface and projected some circles.
Shaded view looks OK to me.
Maybe it’s something in your file or in your Shaded display settings.

Please post:
an image shoeing the problem
your Shaded display mode INI (if it’s not default settings)
a small portion of the file so we can repeat the problem.

"Stbd" means “starboard” or the right side. It’s a nautical term meaning the right side of the vessel looking forward. “Port” or “larboard” (ancient) means the left side. It is also appropriately used for aircraft as in this case.

Hi, images and file attached.
I am selecting stbd and port rivets as I have no easy way of doing one half and when looking at the underside of the aircraft it will be seeing port and stbd at same time so is it that it needs a bring outward command ?

cropped a portion of it and added in another row of slightly larger rivets stbd side, the vertical row at right are different on port and stbd anyway. most are common and same on both and exist as lares for 7, 8.5 10 and 15 as well as panel lines.

TestPortion_BringForward_Issue.3dm (891.2 KB)


Why did you select all of your rivets to bringforward? Try not selecting all the rivets when you bringforward. In whatever view you’re using, select only the rivets you want to see then bringforward on those.

I am needing to show views at various locations as I rotate the fuselage so we have underside, port side and stbd side and topside and its impossible to know what rivets are within view and which not when certainly above and below the fuselage. With having different features some unique to one or other side as layers it might be possible to select out those that are specific and controllable to one side but start rotating things and its tricky.
Bring forward if it means along one axis, and I select port side, how will that treat those on the underside up to the fuselage dividing line ? I need those to go outward as opposed to ‘at me’.

In a 3D world this BringForward is ok for 2D things.

If this was a sphere with circles on it, a command move along normal to srf outwards would be what is needed. This is similar to that

update of use…I am now in Front view adding dimensions which are vanishing as soon as made or part hidden, using BringForward to make the dimensions in the Curve Length Dimension command appear on top of surface, (I have lines proj to surface I am measuring), however the details that were showing ok before, are now sinking into the surface, its as if BringForward is acting a little bit on the surface, my drawing is deteriorating , it was 95% good, now its 70% good. Ruined in fact !

and now another horror, I applied BringForward to dimensions on Curve when in Front view and I see they, as well as a line I applied it to in that view, are appearing in my stbd view in perspective view,

see attached.

How do I solve this, as I dont want to see items from onve side clashing with those on the other side.


I see. There is something wrong about your curves that is causing this. How did you create them?

If I create new curves, project to surface, then your problem disappear. Here is an image of what I see at my end.

Just sent Pascal a video of how it comes about… 17Mb. and test files, also attached here now.

Simply created two surfaces,…my aircraft fuselage sides, bit like you have there, though mine are both silver, then in ortho view I projected rows of circles and some lines onto surfaces. Circles made in array.
In front view select a line and apply dimension on curve, it (figs) lies half buried in the curved surface.

select it and apply BringForward, its now visible…but go to back view and it shows up there as well, also it shows up in perspective view on both faces
select a line and BringForward it now is visible in BOTH views front and back.

I only want to see it better in the viewport I applied it in,

THE BIG QUESTION…HOW DOES ONE UNDO THIS. I have closed the file since to see if it goes away !

Having worked a 12 hour day for weeks to meet a deadline i am seeing double and cant supply visuals and work on the project with everything in transparent mode, I need to see stbd or port but not both.

you say create a new curve and project to surface and it kills those that are showing up in bot views, it removes the problem ? like some kind of antidote to a snake bite ?

Just tried that (create a line, type project and choose a surface) and the new line doesnt show up both in port and stbd but the others that did still do.

I cant go redoing all the work (dims and lines) that didnt until I applied BringForward to them.

TestBringForward_Issue.3dm (107.7 KB) TestBringForward_Issue_V2_afterBringFwd applied.3dm (112.2 KB)


Adding @pascal to this thread.



Could part of the problem be your mesh settings? If you are using “Jagged and Faster” in File>Properties>Mesh, the larger polygons in the display mesh might be hiding part of your curves. Try using “Smoother and Slower”. This might have the side effect of slowing down your display.

Hi Pascal…a very BIG phew and thank you…what a relief…functional again.

Can someone make a MoveOutwardFromSrf command with Direction option, then its directional as befitting a 3D world.

Nick …thanks…tried that following your suggestion, no better.

It is annoying that we have project command but results play hide and seek.