Choppy Lines with new Ryzen 3/Radeon Vega


(Aoguitars) #1

Hi guys! Long time lurker, and I appreciate all that I’ve learned from you to this point.

I recently fell into a sweet deal on a new computer build to replace my Lenovo laptop where I’ve been running Rhino5 for years. Seems super fast, and I love the new M2 SSDs. However, upon loading Rhino and doing a few quick drafts and opening my current work (I am a guitar builder/designer), the wireframe line work is super choppy and not true, clean, lines. Looking around, I found that Rhino5 doesn’t do well with with AMD/Radeon, much to my dismay.

So my question is this–am I screwed with this setup, or can I I get around it with settings? Or by adding a second Nvidia graphics card?

Or, I saw that Rhino6 supports the AMD/Radeon cards…should I upgrade to 6, and will it and my current RhinoCAM play nice? Or if I upgrade to R6, so I also have to upgrade my RhinoCAM?

Again, I appreciate any insight to this. If I have to, I’ll resell this computer and go back to Intel but I figured I’d ask you all who know a lot more about what hardware will work together to get me back looking like R5 should.

Thanks everyone!

AO


#2

No, it will not play at all… Yes, you would need to upgrade to RhinoCAM 2018 to run in V6…


#3

Also make sure you have the latest drivers installed.
AMD Adrenalin 18.5.1 WHQL is the latest:
https://support.amd.com/de-de/download/desktop?os=Windows%2010%20-%2064

The vega gpu should be pretty good for cycles / raytraced display.
From your description I can’t quite understand if you have a desktop or a laptop now. Anyway the driver works for both.


(Aoguitars) #4

I assumed that I’d have to upgrade RhinoCAM too, but I have definitely read differing opinions on that. Thanks man.


(Aoguitars) #5

I will do that as well! And yes, sorry, it’s a desktop. I had been running R5 on my laptop and a second screen for years but don’t really need to it be on the move as much as I did. I will check and see on those drivers…thanks for that.


#6

Hi AO,
1: what resolution is your screen and is it running at full resolution?
2: is Rhino using the hardware and have OpenGL AA turned on or is it running in “software mode”?
3: what driver version is your AMD card using?
4: can you post a screenshot and a sample file so we can compare?

5: have you tried the linesmoothing with the “TestLineSmoothing” command? (just type it in and press enter)

I suggest you read up here before you upgrade anything:
https://wiki.mcneel.com/rhino/5/video/troubleshooting/amd/radeon

and


(Aoguitars) #7

Hi Holo, thanks for the help!

  1. I’m running at 1920x1080, and yes at full resolution. Also, it’s a pretty decent 27" Samsung monitor.

  2. I’ve tried both, and the “software mode” definitely looks better. You’ll see in my screenshots that the GPU makes even the most simple diagonal lines super choppy.

  3. I appear to be using the most recent drivers:
    Radeon Settings Version - 2018.0516.1451.24901
    Driver Packaging Version - 18.10.16-180516a-328911C-RadeonSoftwareAdrenalin
    Provider - Advanced Micro Devices, Inc.
    2D Driver Version - 8.1.1.1634
    Direct3D® Version - 9.14.10.01334
    OpenGL® Version - 6.14.10.13521
    OpenCL™ Version - 24.20.11016.4
    AMD Mantle Version - Not Available
    AMD Mantle API Version - Not Available
    AMD Audio Driver Version - 10.0.1.6
    Vulkan™ Driver Version - 2.0.20
    Vulkan™ API Version - 1.1.70

  4. Screenshots:
    Straight Software-Mode (less jagged)

With GPU and AA:

And when zoomed out only slightly, you can see that almost half of the frets (the horizontal lines) just turn into thick black bars, when there are actually three lines close together.

  1. I tried linesmoothing, and the lines look a little better when I fatten them up. Maybe that’s a solution.

And here’s a 3dm so you can see on your rig.
fingerboard sample.3dm (50.8 KB)

I should also add that I checked out the trial version of V6, and the lines look fine. I know I read that the V6 added support for the AMD/Radeon cards, and maybe that’s what I’m dealing with? Thanks for all of your help!


#8

Ugh… that looks horrible!
@jeff any good ideas?

First off you should raise the AA from 2x to 8x.
And you can try to navigate the drivers and see if you can find an override to raise the AA even further.
(I did this on a v7900 card I had for a while, but it collects dust since I never got over the bad AA. But I thought that was history now)

Here’s what I get in V6 on my Geforce and the lines are a tad thicker than in V5 because of the default GPU tesselation setting that speeds up the linedrawing:


(Aoguitars) #9

Doesn’t it? You can see why I’m pretty bummed about it!

I’m playing with the Linesmoothing that you mentioned and linked to, and it is definitely an improvement to the point where I can just about get it to look normal. If that’s what I have to do, I can make it a default and go with it. It’s absolutely usable, and a MUCH cheaper way than upgrading to V6 and RhinoCAM 2018.

Thanks again, and maybe something else will come up.


#10

Sure and I even happily shelled out $400 to replace the v7900 with a quadro 4000 back then since my eyes just hurt too much trying to evaluate curves that looked choppy and ugly. Spending cash on a fast computer and a great screen and then have a silly GPU mess up all the fidelity just isn’t fun nor productive. Passion for fidelity is just too important to ignore :wink:

Glad it helped you out a bit and good luck on further improvements. Oh, and you can allways trade your card on ebay and get another second hand nvidia. Or uprade to V6 :smiley:

(on my machines I run geforce 1070, geforce 970 and also a small 330m on the laptop, all gives great AA, so unless you work on heavy files, on multiple 4k monitors or renders with the gpu cuda cores then you don’t need an expensive one, but 2GB ram on the card should be a minimum)


#11

By the way, your system info says Vega 8, that’s an integrated gpu chip on the CPU, do you have a dedicated card as well? Some times on dual card setups Rhino chooses to use the lesser one.


#12

No, your driver is not the latest. Use the one that I linked. Though it won’t be of great help since you use R5 not R6. You need to upgrade. Why would you run outdated software that doesn’t support your hardware and makes it difficult to work with (though R6 is terrible as well, but for different reasons). Your tools shouldn’t keep you from getting your work done.
Turns out you don’t have a dedicated vega GPU but the ravenridge APU instead - that is of course not as good for cycles/raytraced than I mentioned, pretty slow actually. But then again you don’t have cycles/raytraced, since you don’t have R6.

Follow @Holo s advice - best advice I can give you :wink:


(Jeff Lasor) #13

@aoguitars @Holo… The screenshots are of V5 not V6… If you’re trying to improve AA in V5, then try running “TestToggleLineSmoothing”…that’s all I can suggest for V5 users…

I am curious though what V6 looks like in the same test cases.

-J


(Pascal Golay) #14

Hello - just keep in mind, you can keep V5 running side by side with V6 and run your older RhinoCAM from that. I assume you’d eventually want to upgrade it to avoid saving as V5 all the time, but it might ease the pain in the wallet not to need to do it all at once.

-Pascal


(Aoguitars) #17

Pascal, that’s awesome news. It’s nice to know that I could still save as V5 and use my current RhinoCAM. Thanks for the help!


(Aoguitars) #18

My apologies. I absolutely used the one you linked to, and it told me that I was now running the most up-to-date drivers. And if R6 is so terrible, why tell me to upgrade?

The LineSmoothing definitely helped, and is absolutely usable as is. I can upload some screenshots with V6 if you’d like. Thanks!

Pascal, that’s awesome news. It’s nice to know that I could still save as V5 and use my current RhinoCAM. Thanks for the help!

And sorry for all of the post edits…I felt it easier to put all of this in one response instead of several.


(Aoguitars) #19

I really appreciate your help and advice, Holo. I’m not against upgrading the GPU or going to V6, so I’ll start researching. I’m not doing anything that’s super intensive at all. I just like it to look good when I do it! Thanks again.