Choosing which display opens when launching

I was rendering in Cycles and the memory use brought my machine to a standstill, but when I try reopening the file, it comes right back to Raytrace. Is there any way to specify which display is first to open, like Shaded?

a simple workaround:
Do a new document with a single layer.
Set display to Wireframe - as this is the less “intense” for the graphic-card.

import your file into this document

you might want to set the rendermesh-quality to less polygons
you find the mesh settings in _documentProperties
or you can set custom render mesh for individual objects.

there might be some approach with schemes - but not sure about - and not worth exploring for a single occurrence of your problem… but to be mentioned:

hope that helps -tom

1 Like

Maybe other option:
Tools -> Options -> Under Rhino Option “General”
-> on Middle Window (Run these commands every Rhino starts:)
-> Command ! _SetDisplayMode _M=_S
This will by set Active Viewport on start to Mode Shaded


Thank you! I did as you suggested and the command said the mode was now shaded, but when I opened the file, it still came in as raytraced. However, it did not launch into raytrace processing, it was frozen, so I was able to pull down Shaded from the drop-down.

Hello - here is a script that will force any raytrced viewport to rendered mode - you can put this on an alias like so:

(Put your own path in, of course, inside double quotes)

You can type that alias any time you get stuck with raytracing bogged down. I have not tried it in a really laggy file though. (407 Bytes)


1 Like

Thank you Pascal. I created an alias and it works just fine.