Changing Text Size - Bug


#1

Hi

I have a Finite Element Grid that I have drawn.

There are 12540 nodes and each node is numbered.

If I want to change the text size from 3mm to 20mm, using the Text Height box, Rhino rushes off and changes everything to 2mm then allows me to enter the 0, and only then changes to 20mm.
In the meantime on my i7 Laptop, I can have several cups of coffees and fume.

It takes longer for Rhino to redraw the text than my FEA program takes to solve all the equations and writes the output file.

I hope someone can fix this

Regards

John


(Menno Deij - van Rijswijk) #2

In the mean time, try selecting the 3 and overwrite it by pasting in the value 20 after copying it off Notepad or something. That should update the value in one go, reducing your caffeine intake considerably.


(Pascal Golay) #3

Hi John- see if the Properties macro works better- bypass the Properties page altogether:

! _-Properties _Pause _Text _Height _Pause _EnterEnd

-Pascal


#4

Thanks for the help. We had a similar problem some years back with the hatching scale, I hope the next release fixes this one. I’ll try the paste option in the meantime
John


(Pascal Golay) #5

My guess is the problem is there are too many objects for the panel to handle quickly and keep up. Using the command line version as I suggested should eliminate this problem.

-Pascal


#6

Hi Pascal

The bug as I see it, is the Text Height should not change as I type but only when the input box loses focus,

We all understand that it takes time to process the data, but it is incorrect to have Rhino doing this

Regards

John