Changing coordinates of geometry (Revit to Rhino)

I’ve got a minor issue/hiccup.
Not sure, but it might very well be a user mistake.
(Crossing my fingers that it isnt a limitation of the plugin.)

I’d like to change the coordinates of geometry from Revit, before i bake it into Rhino.
Problem: Before changing the coordinates for the geometry I was able to output the geometry in category layers.
(see green group)
However, after changing coordinates, the output is all baked into whatever layer is active in Rhino.
(see red group)

Any workaround for this?

The python component is the one baking to layers? That would have to go after the move and be properly grafted.

So far that has been tried.

It is basically the same as shown above, just removed some “irrelevant” components (for this issue).
If I try to bake this specific geometry out, as is, the geometry doesnt group down into “floor”. It just pops into whatever layer is active. In this case “default”.

I guess what im saying is that the data isn’t retained through the transformation of the geometry.
It simply ends up as default geometry, without any data regarding material/information.

Quick explanation:

The reason why i’ve ended up doing this, is that the output from Revit to Rhino places the geometry in a different location (something weird with the coordinates). So I’ve tried to resolve it by manual input (rotation + move)

You are going to have to tell it what layers to bake it on. If you do it before the Element Geometry component it helps you out; putting floors on Revit::Floors layer etc. Once you deconstruct the Revit Element into Brep geometry is just bakes to the current layer.

Typically this is done using the Human or Elefront Plugins.

Well, I managed to get the python component to output as intended.
However i kind of wanted the “geometry cache” component work instead.

Let me flip this around.
Any idea why the output coordinates from Revit to Rhino is off/wrong?
It ends wayyy out in nowhere.
(see below)

Green = Shared Site / Survey Point
Yellow = Project Base Point
Blue = Actual location/coordinates of project site.

Considering that the rotation is off, it seems that RhinoInside outputs with “project north”, instead of “true north”. Regarding the coordinates, I’ve got no idea how or why.
Hopefully it’s a user issue.
I need more coffee at this point.