Changes I did to my model not saving

Hello there,
Today I worked on the 3dm extension model, which is in a rar file. The model autosave also saved it, I saved it myself, but when I opened the model again, I saw that nothing was saved. It says ‘‘archive read error’’. At the time I saved, only the rhl file was registered. I’ve been struggling for 10 hours. Is there any way to get it back?

Hello - if you open a file from a zip file without first extracting it, Windows extracts it to a temp directory and only lets you open as Read Only - you should get a warning to that effect as the file opens. The folder is something like:



Thank you for replying but the file is not in there too. Is it gone?

Hello- I guess I am confused about the ‘bitmap’ part of this - are you asking about a Rhino file, or an image file, or?


The problem is that I worked on the model which in a compressed rar file without extracting it. It autosaved and saved it manually too, but when I reopened the file, I saw that none of the changes I made were saved. I also checked the autosave file and I couldn’t see the autosaves too. What should I do?

Older autosave files are moved by Windows into the recycle bin. I would check there, too.

Actually It’s not an old I just worked on my model yesterday and now I can’t find my autosaves. (I checked the recycle bin)

By old, Bobi meant anything older than the current autosave. By opening Rhino today you may have created a new autosave, relegating yesterdays.

Try the following (assuming you are on Windows 10):

Open File Explorer and navigate to the C:\Users folder, then type *.3dm* datemodified:yesterday in the Search box. That will bring up any Rhino model files, including backups, that were worked on yesterday.

If that doesn’t find anything useful, open the recycle bin and type *.3dm* in its Search box (you can’t use the date modifier in the recycle bin, but you can sort the entries by the Date Deleted column) and see if anything there looks relevant.


As far as I can determine (from reading other similar threads), if you open a Rhino file directly from a compressed folder, it is opened as read-only - you cannot save changes, if you try you will get the “Save As…” dialog and it will not let you save as the same file name.

I just tested this and Autosave should work in this case however. I opened a compressed file directly and made some changes without saving, waited for Autosave to kick in and went looking for the autosaved file - the changes I made were indeed saved. However, I would not want to rely on this.

The default location for this file is:
C:\Users\<your user name>\AppData\Local\McNeel\Rhinoceros\7.0\AutoSave
(AppData is a hidden folder by default, to get there type %appdata% at the windows search box and navigate from there)

Personally I do not recommend opening Rhino files without decompressing them first.

Thanks for your answers. I am trying to open my model file in rar file and It asks a question like “There are updated items, do you want to add them to the archive?” I say yes, but it does not open. The texts like the image I added in my question box appear on my rhino box and then my rar file freezes with the warning “not responding” and I have to close it. I waited for the not responding warning for about 5 hours to improve, but it did not improve. Usually my models with autosave are in appdata and I can access them easily, but this file is not included in appdata although it is autosave. When I search the file on my computer as a 3dm extension, it does not appear either, it is only in rar and it is not updating as I said.

So, you are unable to decompress the .rar file at all?

What happens if you answer No instead of Yes?

As I said, I do not recommend trying to open Rhino files from compressed archives - I think you are just asking for trouble if you do.

I extract my model file from the compressed file, but the changes are still unsaved.

I didn’t try to answer “no” because of if there was a way to get it back I didn’t want to lose it either. I did not transfer the file to the desktop in the first place because I did not know that I could encounter such a problem. I guess I have to work on my model again. :cry:

Did you try the two other searches I suggested above?

Yes, I tried the solution suggestions you gave, but as I said, the file does not appear anywhere, it only appears in the rar folder. A box appears for me to update, when I click “yes” on it, the rar folder is not responding and it freezes and cannot update the model.

Bad luck.

Which .rar reading app are you using?

I’m using WinRAR.

What happens if you run Winrar’s Test function on the archive?

It says “no errors were found during the test process”.

If you go into file Explorer and look at the properties for the RAR file, has Windows blocked it?