Center lines etc never show the dash dot until heavily zoomed in on..why?

I rarely can see the dash dot of a centerline until I zoom right in, I wish it showed dash dot at any mag,

Do others also experience this ?


I thought exactly the same thing only this morning. I changed a line to a centreline but as soon as I zoomed out it looked like all of the others.

I assume there is a setting to change it somewhere, I’ll have a look but hopefully somebody that knows what they’re doing will chip in.

Hi Steve - the line type in the viewport is set in model units and not screen sizes - that is, they scale with the view … but LinetypeScale may help.


Hi ,
would this be SetLinetypeScale ?

it says to type a scale, now what scale do I type so that we see dash dot at whatever zoom we are at ?

I reckon if we select centre as linetype we should by some default behaviour see that centerline anyway, rather than have to zoom right in to see it.

sort of basic requirement. goes without saying sort of thing.


what scale should I type to see a dash dot at any zoom level ?



You can’t. [quote=“pascal, post:3, topic:32806”]
they scale with the view


I select a line then run command SetLinetypeScale
it says New linetype Scale<1>: and expects an entry

so wondering what do I type ?

I need to see the dash dot at any zoom amount.

ok, lets try a 4, hit enter zoom out and its a continual line again.


Think of it as a scale.
If you look at the linetype definitions, they are drawn in mm or inches. The Hidden pattern is 2, 2; meaning at actual scale, 2mm dashes will be spaced 2mm apart.
If you’re Zoomed back so you’re seeing 100 mm across your viewport, then you probably want a scale of about 1.
If you’re Zoomed back to 1000mm, then 10 would be a better factor

Hi, trying a few different numbers,
2inch line
with 5 shows dash dot dash dot dash

10 shows dash dot dash. and as I zoom outwards its still dash dot dash, becoming the right length of dash, so rather than it being a pattern always showing a 2mm long dash if measuring dash with ruler on monitor, it is scaling, so there is only one zoom level when it looks ok, then one more scroll wheel click outwards and its a solid line,

I want 2mm long dashes as measured on monitor at whatever zoom level I am at.

This is giving the right number of dashes (length of dash measured on screen) at just one zoom level.


As Mitch said before, there is no setting that keeps the pattern the same on the screen at any zoom magnification. That would be useless in any traditional drafting standard.

The only thing in Rhino that stays the same size on the monitor at any Zoom magnification is the Annotation Dot.

I seem to recall when with Macromedia Freehand we had dash dot which gave us a steady unchanging length of dash whatever zoom we were at,. I personally find it more useful than having the line go solid.
2 inch long hinge centre line with just a dash dot dash when zoomed in is meaningless, zoom out and one starts to see a centreline as expected with a number of dashes then it goes solid.

Increase the number of dashes by altering scale number and it looks good when close in, but it solids up as soon as you start to zoom out.

In my book to see a dash dot dash line with e.g. 2m long dashes as measured on screen at whatever zoom level one is at makes sense.

What do other Rhino users wish to see ?