CCX - Parallel Computing - Issue

I upload a situation where Parallel Computing seems to create a problem:
if I enable the Parallel Computing my solver stop working.

unnamed.gh (120.4 KB)

thanks for your support!

Make sure both input data is grafted. Parallel still takes longer, but that’s a different problem.

(removed pic).

Edit: Hm, but that’s perhaps not waht you want to do. It would have been a good idea if you had explained that Rhino hangs of using parallel. Rhino crashed.

// Rolf

did I raise this issue in the right place?

Are you running the latest service release of Rhino? We fixed a few threading issues with grasshopper in recent service releases.

I thinks so, this is the version: 6.8.18240.20051, 08/28/2018

Rhino 6.10… here.

// Rolf

I have the same bug here. When using parallel computing with CCX it gives wrong result. The solution for that is to turn off parallel computing. Using Rhino Version 6 SR16 (6.16.19190.7001, 07/09/2019)
Parallel%20computing%20not%20working Parallel computing not working.gh (54.2 KB)

1 Like