Case Sensitivity of Rhino

unhandled
casesensitivity

#1

Hi,

my Turkish Q keyboard types “İ” (upper case i) when i press lower case “i” if casp lock is on. Obviously this is an expected behaviour.

But while spliting a surface i usually hit “i” for isocurve and this where uppercase “i” problem emerges for me. Rhino does not know uppercase “i” and says;

"Select cutting objects ( Isocurve Shrink=No ): İ
Unknown command: İ "

Does anyone have a solution for that? except turning off the capslock because i dont turn it on knowingly. “tab” , “shift” and "capslock " are too close. :frowning_face:

by the way there are no other exception other than that for Turkish keyboards.

Regards Rasim


#2

Are you sure your keyboard is actually transmitting an uppercase I? Here a US-English system/keyboard works fine when using an uppercase I to activate “Isocurve” in Split (V5 and V6)…

Your uppercase I has a dot on it… It shouldn’t.

You may actually be sending this:


#3

yes in Turkish we have ı , I , i and İ.


#4

but just the uppercase “i” with a dot is problem. i dont hit the lowercase “ı” key without a dot.


#5

Aieee…

I don’t know if the command line is interpreting in Unicode or just ASCII extended, the İ is only available in Unicode (U+0130)…


#6

hi,

i realised that same problem happens with “div” for divide, “pip” for pipe, “mi” for mirror …


(qythium) #7

You could try setting an alias from İ → I ,this works on my side for Split isocurve and other single-letter “i” commands.

Unfortunately this won’t work for the other commands unless you manually add variations for every one ( DİVİDEDivide etc.).

At the root of the problem, why not try using SharpKeys or similar utility to remap CapsLock to something more useful? :slight_smile: