Capping Issue

I can’t properly cap the end of this orthotic sole that i made in rhino. For some reason it always come out very bad and with kinks.

Any tips on how to solve this???
Help.3dm (7.5 MB)


Hi Simon - this type of configuration generally works well-

Where the red surface is trimmed by the U shaped blend curve.


1 Like

Pascal, what command did you use to create that surface please?

I think he used the sweep 2 rail to do that

QuadRemesh and SubD tools are ideal for organic forms like insoles…

Help_SubD_mrtn.3dm (8.1 MB)


Thanks Simon

1 Like

Hello - yes, Sweep2 in this case to get a surface in there but it does not really matter all that much - the main thing is to set up the rectangular hole to fill - four-sided - then use the tool(s) that work best for the design to fill it.


Did you use Rhino 7 for this uh? That’s really cool but i don’t know how SubD works unfortunately… :frowning_face:

1 Like

Rhino 7 / Beta

Something new to learn then…


Any tips on how to get a bit more fluent curvature on these surfaces?
I really suck at this
Help 2.3dm (7.9 MB)

It is best to start a new thread when asking a new question. More people are likely to look at a new topic than an old topic they may have already looked at.

Reduce the number of control points. The goal should be to have the minimum number of control points needed for the shape and accuracy required by the design while keeping control point nets aligned across edges. (Note that “Absolute precision” in “Units” in “DocumentProperties” should be on or two orders of magnitude tighter than the accuracy required by the design, at least for the initial phases of the design.)

1 Like

@simon_falze - rather than add that little U-shaped patch to make the heel surface, try ExtendSrf or Untrim on the one it is attached to, and trim the U-shape out - that way there is guaranteed continuity there, one less set of edges to think about.

Also, for the Zebra, before you get to simplifying the surfaces as David suggests, set the mesh to be very fine in the Zebra control > Adjust Mesh > Detailed controls > Minimum initial grid quads > ~5000 or so. That will clean up the display so that when where it looks junky it is really likely to be the surfaces and not the analysis mesh.


1 Like

I’m actually now tinkering and learning about these SubD…Any recomended setting when using the QuadRemesh Tool?

Try and error. The settings depend on many variables / goals