Cap planar holes

I have this problem with cap planar holes. Extrude curve with 1 rail to get this surface. But when a cap the planar holes I get this strange problem.

Rhino 6 in windows.

Hi Kris - from that picture, it looks like tangent surfaces are not split and, as such, that behavior is not unexpected. When you are in a display mode that shows edges of surfaces, you should be expecting a visible edge in this area:

Before capping, please try to run the DivideAlongCreases command before you select anything.
Then set the SplitAtTangents to Yes and then select the object. Then try capping again.
If that doesn’t solve it, please post the 3dm file. That will tell us a lot more than a picture.

Not unexpected, but unacceptable

Well… I don’t necessarily disagree but I take it that the ExtrudeCrvAlongCrv command was used here. That command has a SplitAtTangents option that seems to stick between sessions.
Why anyone would ever want to set that to No is beyond me…

It worked !
Did what you say to do , DivideAlongCreases command and set the SplitAtTangents to Yes.
Al good now.

I used the sweep1 command to extrude the curve along the rail curve.
Thanks 4 the quick reply.

Thanks, Chris.
As you notice, that command doesn’t have a SplitAtTangents option.
There’s some more background reading here: RH-51814.