Can't use smarttrack to starting point: Polyline/Curve Command

Can’t select the initial starting point for the polyline/curve using OSnap.

Seems to be working here… --Mitch

Hmm,
Uploading an vid. https://aws1.discourse-cdn.com/mcneel/uploads/default/original/3X/3/f/3fb7cce98c0cd3fa15a379587f972564180ebe58.mp4

I’d like to use the first point as reference sometime to get ortho or perp.

Just finishing/closing the curve is working ok(if not pressing Alt for OSnap).

Well, still seems to be OK here with the curve command…

video (sorry about the Flash format, have to get a better screencap program than Jing now…)

–Mitch

Seems OK here as well.
Toshiaki, I can’t tell which snaps you have turned on. Also, I don’t really see if it snaps to points within the curve.

I am seeing something peculiar here though.
When I turn off my point snapping, as expected, I cannot snap to the points of the curve-to-be.

As opposed to when point snapping is on:

So far, so good.
But with point snapping turned off, I can still snap to the start point of the curve and the mouse pointer will say Point:


Even when all snaps are turned off, it will report snapping to Point. Perhaps the wording here should be something else - e.g. Closed?

Hmm…

I have End/Near/Point/Mid/Cen/Int/Perp/Tan/Quad/Knot/Vertex selected and also Disabled. Then normally press Alt to turn them all on.
It’s when I’m pressing Alt that, I fail to snap to the initial point.
If I don’t press Alt, I can snap to it.->But still I can’t get ortho in either case…

I also need a better capture program than the windows default(win key + G)… to heavy…

Hi Wim, Thank you four your feedback as well.
I’m not trying to close the line, but want to get use it as reference so I can make a ortho/perp point from it.
->I should have perhaps said SmartTrack. I’ll change the titile.

I usually have Disable ON, then use Alt key for the Snap (or smarttrack)
but in the case for the initial point I can’t catch it.
Having all Osnap disabled I can indeed get the initial point with “Point” shown.

After watching your video I got it now.

  1. It seems to get the Smarttrack working I need to have Osnap disabled (so in my case not pressing ALT)
  2. then, go to the initial curve and sort of activate the Smarttrack by hovering over the point.
    3)Then I press the ALT to turn on Osnap can use Ortho or Perp from the initial point which has been “Smarttrack activated”.

Feels kinda weird tho…

OK, I see that too, with Osnaps disabled and Alt pressed, I can snap to all the points except the start point…

–Mitch

It does feel a little weird - apparently, the Alt is also toggling the built-in snapper that should find the start point to close the curve… let me see if that is intended or indeed what is going on.

https://mcneel.myjetbrains.com/youtrack/issue/RH-42192

thanks,

-Pascal

1 Like