Can't stop Raytrace and UI gets stuck [Solved]

When setting Raytrace for the rendered viewport, when poping up windows the UI get’s stuck and
also the Raytrace can not be stuck.

-When raytrace sampling set to high number, can’t do anything until viewport finishes the sampling.

Happens often when material editor opened, double clicking to change the color of the material.

Hmm, have you changed the throttle value (default 10)?

Also, try pressing alt-key when you try to open a dialog, but it stays hidden (color picker). It probably will pop up again.

This is a problem that every now and then seems to pop up (pun intended). Many times already thought to be fixed.

I’ll check up on the throttle value.
Meanwhile I had a meshed file turned Nurbs and the file was couple of hundred MBs. maybe that also is causing it.

Could be, if it adds even more geometry to render.

The Alt-key worked to get the dialog to the front.

But, still using the dialog/ moving mouse sometimes gets a bit heavy.
The current one didn’t have as much geometry so maybe I’ll try with throttle value to see how that changes next time.

If you have transparent or reflective materials, especially on lots of objects rendering gets quite heavy.By default we do quite deep transparent and reflective bounces, up to 128 per ray. You could play by setting them lower, but if you rely on good inter-object refraction and reflection you need to keep them high enough to prevent black objects. To see what I mean add a couple of reflective spheres close to each other, then set glossy bounces to 1. (remember to toggle between another mode and Raytraced to use the changed setting). Then keep bumping the glossy bounces and restart Raytraced to see what I mean.

zero glossy: image

one glossy: image

four glossy: image

128 glossy: image

Thanks Nathan, I’ll try that too.