Can't set 'Redo' to shift-cmmd-Z


#1

i just can’t get used to cmmd-Y for Redo (grasshopper’s default setting)…

when trying to assign it to the normal shift-cmmd-Z (in grasshopper preferences / interface / edit), it doesn’t seem to allow the use of the command key as a modifier… so the closest shortcut that grasshopper will accept is shift-Z.

is it possible to allow the command key as a shortcut key?
thanks


#2

here’s a weird one.

if i set the shortcut using these keys : Shift - control - Z,
the shortcut will be shown in the preference panel as Ctrl+Shift+Z:

if i then try to use Shift-control-Z to Redo, it doesn’t work.
however, i can now use Shift-cmmd-Z and it does work :wink: (which is what i wanted in the first place).


i guess there’s some sort of mixup with Ctrl key and mac’s control & command keys.


(Dan Belcher) #3

I think we just need to Mac-ify all the shortcuts, if that makes sense. See: RH-36843.


#4

yeah, i personally think that would be more important or take precedence over keeping the shortcuts similar between the versions (‘similar’ because they can’t be the same… there’s no ctrl key on mac… there is a control key… but the key typically used for mimicking ctrl is cmmd … etc)

besides Redo, a few others to have a look at:

cmmd-Q for toggle preview? hmm, i would say this should definitely mean Quit.
cmmd-M should be minimize (instead of mesh preview)
cmmd-comma for preferences

possibly cmmd-F for Find as that’s what i always use in Numbers,Preview,Safari,etc…
though i suppose cmmd-F is pretty good for ‘bring to front’ in grasshopper.