Can't see CRVs which are there

I downloaded two sets of CRVs.
One set is okay, but the other one has a problem:
I can see CRVs when they are highlighted, but only a few of them if they are not.
What could be causing this issue?
I moved all of them to a single layer, which I thought would solve the issue, but no such luck.
I’ve also discovered that when I try to add new CRVs in the same spot as the existing ones they also disappear until highlighted. It’s as if there is something in front?? but there’s nothing to choose there.

Perhaps they have their color set to the same color as your background? (i.e. not “by layer”)

Great suggestion.
I highlighted the CRVs and chose a new color, some of the CRVs appeared, but not all.
Any other ideas for the other CRVs?

Can you post just the ones that didn’t become visible?

icrvs.3dm (50.0 KB)

I take it your background color is white?
All but 6 curves in that file have their Display Color set to ‘White’. If I set that to ‘By Layer’, they become visible for me (on a white background). As in the attached. Doesn’t that work for you?

icrvs-by layer.3dm (120.7 KB)

now I see everything reversed… what was seen before is now not, and what wasn’t is:)
in any case, I might be missing something.
but first, yes, my background color is white.

okay, so the last time you mentioned changing the color of the crvs, I selected them, and picked a color, which changed the color, but as soon as I de-selected, they were gone again.

I can select the crvs and move them all to another layer with a certain color, but again, same story.

So what is the difference between that and what you just said?
Can you tell me what you’re clicking step by step?
Thanks so much for your patience:)

Hi Izabela- did the curve come from a dwg file? If so, can you post or send me the dwg?



Are you by chance in a display mode that is hiding curves? I once copied the Shaded display mode and set it up to not show Isocurves and accidentally set it to not show curves. So after I would draw new curves they would disappear. This took me a couple hours to figure out.

Spooky… :wink:
Where did you change the color?
How did you see that the color changed when the curves were still selected?
Why not just set them to use the color of the layer?

is hiding crvs a setting to the ones selected or to a layer? because since I put them all on a single layer and selected “show”, which I assumed was opposite of hide, nothing happened.

yes! :slight_smile: here it is
1.dwg (31.4 KB)

Well… You could be correct. I put all CRVs on the same layer and changed the layer color, which made them all pink. Now, since the ones I could see did turn pink, I assumed all of them did and I just couldn’t see them. Howeveeerrrr… you know what they say about assumptions:)

When I open this dwg file, there are 3 layers: Default, 0, and WORK.
There are no objects on Default, 23 objects on 0, and 124 objects on WORK.
Layer 0 is white and its objects all have “Display Color” set to “By Layer” (and thus they are invisible on my Rhino).
Layer WORK is yellow but all its objects have their “Display Color” set to “White” (and thus they are invisible on my Rhino).

So for it to work as you want, do not change the layer color (well … yes, the white one to something else) but go to the Object Properties and set the Display Color to By Layer.

@margaret, I’ve been trying to find a screen shot of the object properties panel in the Mac help but couldn’t find it. Perhaps that could be added to the properties page?