Can't run v6, retail or beta. Error message states "VCRUNTIME140.dll is missing"

I was running v6 beta, but haven’t run it for some time. Running v5. I just upgraded to v6 this morning.

Last night I tried to start the beta version and got an error about vcruntime140.dll missing and a suggestion to reinstall the program. I just uninstalled it and installed the new upgrade version I downloaded this morning. Starting that gives me the same error. v5 still seems to be working.

Any ideas?


Found a download from Microsoft for Microsoft Visual Studio ++ 2017 x64 and installed that. It works now.


@montejw360 what download did you use? It seems pretty bad that Rhino doesn’t come with or install everything you need.

Brian, download for Rhino? v6 beta, I couldn’t tell you at this time, too long ago. The upgrade came off the web site, download link given after making the purchase.

Hope that helps.

It does. @montejw360 can you please also send me the contents of Rhino’s Help->System Information?

I’ve logged this bug as RH-44361.


@brian, here’s the text from Help > System Information:

Rhino 6 SR1 2018-2-6 (Rhino 6, 6.1.18037.13441, Git hash:master @ 5a33e6871b94d32ba552468218cef0ad8d3d1263)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Quadro FX 4800/PCIe/SSE2 (OpenGL ver:3.3.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 3.3
Shading Language: 3.30 NVIDIA via Cg compiler
Driver Date: 11-14-2016
Driver Version:
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 1536 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

RH-44361 is fixed in the latest Service Release Candidate

Cool, glad I could “help”. Though I’m sure everyone in development has plenty to do as it is.


I faced the same problem. However, as Microsoft Visual Studio ++ 2017 x64 was already installed on my computer, I repaired the installation. Then, it worked.