Can't open a file because of "Creating meshes... Press Esc to cancel" that doesn't comlete

Like the title says… I have a file, pretty big at 445MB, that I can’t seem to work on anymore.
When I open it in Rhino 6 there’s the “creating meshes” message that won’t go away and if I do something Rhino doesn’t respond anymore…
I think I remember having this problem in the past but it went away. But now, what can I do?

You can try to Import the file into a new file where all views are wireframe.

Sounds like the file is too big for your system (videoram run out maybe) Too dense meshes?
Can be a bug in V6. Can also be bad objects.

All the views are wireframe…
I have files bigger than this one that I have no problem with. CPU and RAM are very low when this happens.
I have 128GB RAM and 24GB video RAM…
In Rhino 5 there’s no problem with the same file.

Sure, sounds like a bad object or a bad setting.

As I understand it this IS a V5 file that works fine in V5, but opening it in V6 causes issues, is that right?

Did you try to import it into a new document?

If not then do this first:

  • Start by setting units to the same value as in the trouble file.
  • Then set tolerance to 1 unit.
  • Then set custom mesh settings like this:
  • Now import the file.
1 Like

Thanks for your time,
I was not able to correctly debug it… I tried to show objects layer by layer to catch the culprit but now the file is fine…
Probably an object with shutlining applied because the last crash was when I panned towards it and just when it began to show in the viewport.
I’ll try to deep further into this when I have a few minutes.

1 Like

It looks like a meshing problem with shutlining.
There’s no bad object and it shows the problem with or without custom render mesh (in the object’s properties)
I was able to work with it by;
-importing the object in a new file and keeping it out of any viewport.
-ungroup the objects
-select polysurfaces and turn off shutlining in the properties panel
divanRv6.3dm (3.3 MB)

1 Like

The mesher has definitively some problems with this polysurface…
For all kinds of rendering mesh creation Rhino becomes unresponsive with 0% CPU usage.
Staying in wireframe view in all viewports, it still wants to create meshes at random occasions.

1 Like

Hi Marc- thanks, I see something is amiss here for sure.
Hm - I was able to get it to behave by running 4View immediately as the file starts to open. Once it revovers and opens, it is fine even with the grouped objects and shutlining sill on. Shading a view is not a good thing though, unless shutlining is turned off first.
@Marc Did this ever work in this file? Were you able to get a tractable shutlining display previously?

https://mcneel.myjetbrains.com/youtrack/issue/RH-37852

-Pascal

It was created in v5 and I had no problem there…

Hi Marc - ok, I see… thanks. I added a file and comment to the bug item.

-Pascal

Thanks Pascal

Was this work done on a 4K display or 1K? I am seeing significant lowdown on a 4 K display; 4X or more.

@pascal I found a really weird work around this issue. I also was waiting eternities for large files of +300mb to finish “creating meshes” when you open it. If you open the same file in read-only mode, as in have two copies of the same file open, the second read-only file will load super fast while the original is still creating meshes. I just close the OG file and re-save the read only. Annoying but it works for me.