Can't meshboolean split in quadrants?


(Teh255) #1

Hi I am trying to make a negative of a model head to cut from a 5 axis CNC router, but in preparing the file I cannot split this box into four quadrants. I don’t understand why, as I was able to meshboolean split the modeled head from the mesh box I created around it… perhaps self intersections or small triangles.

Please assist.

Thank you,

Taylor

I am running Rhino for Mac


(Wim Dekeyser) #2

Hi - the mesh tools haven’t been Rhino’s strongest side and are being worked on for Rhino 7.
Perhaps you could try to split the head from 4 quadrant boxes instead of trying to split the one box into 4 after the boolean operation? If you post the model, maybe someone might have more tips…


(Teh255) #3

thanks! I’ll try that! here is the file wojnarowicz head negative.stl (9.0 MB)


(Teh255) #4

Thanks Wim! I ended up reducing the mesh by 25% and then it worked… go figure! I still am working in Rhino 5 but will upgrade later today!


(Wim Dekeyser) #5

Our current mesh intersector doesn’t like situations very much where triangles have very different sizes. When you reduced the mesh, perhaps the new triangles were a bit more of the same size where they intersected.

Another thing you could try if you run into this again, is using a voxel-based plugin (like Dendro or Crystallon) to do the boolean split.