Can't get out of block editing

My experience has been that if I save a project from block edit mode, it will open in that mode but without the block edit box.

1 Like

Yes I noticed this too, on the latest Rhino v6, spent ages trying to figure out how to get out, ended up using unlock to get out.

Ok, it happened again, this time by pasting a point into a block, it greyed out the block edit box buttons so the only thing i could select was the X. It locks everything on Off layers as well so it’s not just a case of using the Unlock command, this needs to be done with all layers turned on.

I saved my layer state, then turned all layers on and unlocked everything. Then reloaded the layer state, this would have worked well if the block wasn’t now exploded. So I now either re-insert and re-position the block or close the file, lose the work and start the changes again.

EDIT: I’ve been able to copy the block from the previous saved file (I hadn’t saved the file during this issue) so i have the block back in its place and everything is now back to normal. So this is a work around the problem.

Can there be added a manual ‘Exit Block Edit’ command?

1 Like

Hey there, same issu with me, it happened several times, while editing a block, the file crashes and a crash file is created. Then when i open that file, the block edit dialogwindow has disappeared and i can’t get out of it. Tried to close the file and re-open. Didnt work. Tried to turn off the computer, didnt work either.

Finally i unlocked the rest. now i have my block exploded.

If anyone found a way to get out of editing the block without exploding it, it would be grate to share !

Each time it happened, i was working and editing during a long time the block.

Do you get the crash report dialog and send it in? If you are not getting the dialog, please see if you have any files with “RhinoCrashDump” in them.

Also, please run the Rhino SystemInfo command and paste the result here.

… on your desktop

I lost my block edit window as well. I can’t exit the block without it, so i have to shut down rhino 6 to get out. Unfortunately, I can’t ever edit any blocks that I’ve made since I can’t find a way to get my block edit window back. Anyone know if there is an “exit block” command? Anyone know how I can get the block edit window to show up again? I can’t work at all without this. Thanks!

Hello - please try running testResetWindowPositions. (type or copy/paste the whole command)

Any luck?

@JohnM - do you have an idea?

-Pascal

Thanks for responding. I tried it twice, but nothing. All the windows I had docked on the right side went away (I had Properties, Layers, etc), but the block edit window is still missing. Is there anything under the Panels tab that I need to check to get hte window back?

Unlock gets me out of block edit mode, but I am unable to edit any blocks after that, so I’m not sure it’s working properly either. I’m able to modify orphan geometry, though.

Please run SystemInfo and post the result here.
Does the issue happen with any block or a particular file only?

Does block edit work if you create a new model, make a block and try to edit it? If so could you send me a model where it does not work and I can take a look at it.

I tried creating a new file and running Block edit on that. Same Issues. I could get into block edit mode, but the window won’t pop up. When i unlock all, I don’t think i get completely out of Block edit mode, because even though I could modify regular geo, running the Block edit command wouldn’t let me select blocks. ??? I finally uninstalled Rhino and reinstalled and now the block edit window comes back. thank you!

Hi guys, thanks for all the good info, just so happened to come up with a “hack” to get back the window if you don’t want to, or cannot “unlock”;

  1. So, we all agree that the “Block Edit” dialog window seems to disappear at random moments during work in progress. for me, its as soon as I click on screen, however…

  2. If you click on your taskbar (for PC - if you run mac you have bigger problems anyways that your probably working on :grinning: jk), open a web browser or another program and click your task bar icon for the web browser, opening a browser window, then click back on the Rhino icon in your task bar. Do this once or a couple times and your “Block Edit” dialog window is bound to show up!

Ah Rhino, we love you. Hope this helps!

1 Like

Hi Everyone, I just had this same problem and I found a solution to the problem.

If you have the block edit window, press Add Object. You will be able to add all of your lines and geometry that is not in the block. Press enter or OK, All of the geometry will be added to the only available block but now you can explode that block and you will have all of your geometry.

I find that it is best to just copy and paste the block into an entirely new project browser and save it separately. Although it doesn’t completely solve the problem, it will save you hours or days of work.

1 Like

Hi - as I understand it, this thread is about a situation where that dialog window is not visible.

Could you describe the problem that you are trying to solve?
Also, please run the Rhino SystemInfo command and paste the result here.
-wim

I had this same problem - just type ‘unlock’ < this will solve the problem

Thank you for the ‘unlock’ suggestion and the others who provided alternatives. It helped!

1 Like

I am having this issue in Rhino 6 current version. I had locked objects in my block, so when I typed unlock they unlock. After that, unlock has no effect and my Blockedit window remains gone. OTher suggested remedies above have no effect.

The issue began when the Blockedit window refused to respond, with all options greyed out. There was no command active, and I could not close block edit, so I pressed the x button and the window disappeared and I am stuck in Blockedit. Saving and closing… But it just opens in the same unusable condition.

My fix in such a situation is to open the unusable file, copy the most current items from the open block, and paste them into the most recently saved version (because it appears the programme won’t autosave when it’s editing a block., is that correct?)

@JohnM - do you have any idea what might be happening here?

-Pascal

Closing Block Edit window (with X button) with adding or removing an object command active may be part of a sequence of commands which created this.