Can't get 1 rail surfaces to join


#1

I created a few fairly simple objects via the Sweep 1 Rail command and am now trying to unite these surfaces into solid objects in order to export for 3D printing. However, I’m getting lots of errors and Boolean fails when I try to unite the pieces. Sometimes I can get one or two elements to unite, but then not others. I haven’t worked in Rhino for a while and I’m having a hard time navigating what the issue may be.
A_Duncan.3dm (1.8 MB)


#2

Some strange stuff going on here. First run ungroup multiple times. Then use split at isocurve to convert your surfaces objects into polysurfaces. It looks like union doesn’t like working with untrimmed surfaces and polysurfaces. Then delete all the planar bottom surfaces. Join and run cap. Hopefully someone has better method.


(Pascal Golay) #3

Hello - it looks like the large sweeps are single surfaces for some reason - use DivideAlongCreases to make them into polysurfaces (splits at the hard corners) then BU will work. MergeAllFaces after to clean up.
Run the CreaseSplitting command and make sure that is set to Yes to avoid this happening (hopefully) in the future.

-Pascal


#4

That worked perfectly! Thanks for the advice