Can't fillet voronoi surface for trimming

Hello! I´m having a real headache with the voronoi trims :frowning:

I want to cut the round surface with an organic looking voronoi so I tried with fillet-edge (fillet curve was not working either) but it´s still not possible. (1st and 2nd photo)


I was also wondering if it was possible to also fillet the polysurfaces edge in the same opperation, this may be harder so I wont even try, if I cant do it its ok. But I am trying to reach the organic shapes of the last reference photos.


Thanks, really, this is real helpful.

Sorry forgot the fiiles :wink:

kalil (10.8 KB)


This seems to be a job for MultiPipe, not for a mechanical fillet.

kalil (12.2 KB)

Fillet Edge requires a list of edge indexes, but even if you supply them, I don’t think it’s what you want in this case. I don’t see anywhere that you have the Voronoi holes in a thick brep? You need to get something like this first, and this isn’t the only way or best way to do that. Even then, I’m dubious that Fillet Edge will work, but it doesn’t hurt to try. (11.3 KB)

This is a better way to create the holed “Closed Brep”. (white group) I made an effort to get Fillet Edge to work but didn’t quite get it right. (gray group, “DISABLED”) Even with the correct list of edge indexes, I believe it will fail on this holed shape, based on experience. (33.4 KB)

Hello! thank you so much! When tried to open the file it says that I need the Multipipe plug in, does anyone knows where can I download this? and how can I find it, I´m looking for it

You probably need to update your Rhino to the latest version.