Cant draw anything


(Ryangrandolph) #1

I cant draw anything in rhino 6. everything I draw in wireframe is invisible. I can select it but I cant see it. I just installed it and did one drawing fine and hit undo and now everything is invisible in wireframe


(Nathan 'jesterKing' Letwory) #2

Please do paste the textual contents of the Rhino command _SystemInfo. In all likelihood you need to update your drivers, but hard to know for sure without knowing details.


(Ryangrandolph) #3

Rhino 6 SR0 2018-1-16 (Rhino 6, 6.0.18016.23451, Git hash:master @ c0b115e88c59340755c25f7822e172c79c9b530b)

Windows 7 SP1 (Physical RAM: 16Gb)

GeForce GT 430/PCIe/SSE2 (OpenGL ver:4.2.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.2
Shading Language: 4.20 NVIDIA via Cg compiler
Driver Date: 8-30-2012
Driver Version: 9.18.13.623
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1048256 KB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Ryangrandolph) #4

this is the info on a curve that is invisible

curve

ID: 295390a8-782b-4b48-a795-16cf77782ed6 (77)
Object name: (not named)
Layer name: Default
Render Material:
source = from layer
index = -1
Attribute UserData:
UserData ID: 563238F9-C201-411d-A7B1-13895A0317AD
Plug-in: Rhino
description: AutoPointsOn
saved in file: no
copy count: 1

Geometry:
Valid curve.
Circle
start = (3.24145,4.28499,0)
center = (-4.52984,4.28499,0)
radius = 7.7713


(Steve Baer) #5

This is probably due to older display drivers reporting that they support GPU tessellation when they really don’t. The first thing I would try is to see if you can update you display driver. If that doesn’t work or a new driver isn’t available, then turn off GPU tessellation on Rhino’s OpenGL options page


(Ryangrandolph) #6

I turned off GPU tessellation and all is back to normal. Thank you so much!


(Wim Dekeyser) #7

Well, yes. But that’s not necessarily a solution - you will not be using the vastly improved display features of Rhino 6. Your GPU drivers are from 2012. According to this page, there are drivers that were released on Monday that support that card:

https://www.geforce.com/drivers/results/130631


(Steve Baer) #8

Wim is correct. GPU tessellation is a very good feature to hace enabled as this is the feature that can dramatically improve the speed of drawing all curves and surface wires in Rhino. Updating your graphics driver is the best first thing to try.


(Navarro) #9

Just wanted to add myself to the “outdated” club.

GeForce GTX 660 Ti/PCIe/SSE2 (OpenGL ver:4.3.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.3
Shading Language: 4.30 NVIDIA via Cg compiler
Driver Date: 1-18-2013
Driver Version: 9.18.13.1106

My drivers -updated- from Sept 2013 are not enough. :frowning:


(Navarro) #10

Where can I find all the stuff I’m missing? (just to feel sorry for my self in a more accurate way)


(Nathan 'jesterKing' Letwory) #11

You also should update your GPU drivers - check the link @wim posted earlier. Your card also supports GPU accellerated rendering in the Raytraced viewport mode.


(Navarro) #12

My bad! Thanks for your patience, now works like a charm


(Ryangrandolph) #13

Updated my drivers and now i can run with GPU tessellation on and everything runs fine now. Thanks