Can't delete reference layer

Hi Pascal,

File has been uploaded via your site.



Spoke too soon. I get this error :

AccessDeniedInvalid according to Policy:
Policy Condition failed: [“eq”, “$acl”, “private”]-


Did you ever get this file upload problem sorted?

I got a message from Pascal saying he had the file but have not heard back since. I still have the problem.


Hi Nick - I did download a file but (and I am sorry, I thought I had emailed you back, apparently I did not - apologies for that) the weirdness continues - the file is completely empty…


I had a similar problem, even after exploding blocks, purging and deleting all blocks in blockmanager, the reference layers remained. However when i closed and reopened the file all the empty ‘undeletable’ referenced layers were gone!


Hi, it seems like almost a year later, this problem still persists even in Rhino 6.

I have purged, manged my blocks, deleted everything, tried saving in multiple different files, copy and pasted into new files etc etc and still I cannot remove a reference block. The biggest issue being, that every time I want to save the file, I cannot save without also embedding the very large reference block. This makes the relatively simple file very slow and heavy. So much that Rhino often becomes irresponsive.

Has there been any resolve to this issue?

1 Like

Hello - can you please send a file with the undeletable block? ( , to my attention ) What do you mean by ‘reference block’?



I can’t due to confidentiality.

I meant reference layer, but the object that is on this layer is a block instance. The block is a large 3d model (3d scan) that was originally in sketchup, roughly 240mb. My Rhino model is only 5mb. I was using the scan to model a landscape around it. Also, Rhino is have a hard time with this 3d scan, when I import it, the file size just goes through the roof, from the original file size of 244mb to over 1.6gb. I have tried all that I know to get the file size down, including removing any plug-in data, reducing the amount of geometry, purging, and lowering the amount of polygons. So, when I also can’t remove this reference layer with this very heavy block, my files are very large and Rhino often crashes or is just not responsive, for even the most simple of command, like select.

I had discussed this in: V6: Making a Better Block Manager

My workaround, and yes it is only a workaround is to create all blocks on the “Default” layer, as it exists in most Rhino 3D drawings, and most people don’t delete it.

Though, when you export things to say a .stp file, it makes a mess for the receiver.

Hello - is the scan a single mesh, in theory? Does it come in as a block instance? What does BlockManager show you?


Is there a reason you can’t use a worksession instead?

Same problem here. I just got used to copying stuff I need to a new file.

Hi Jarek -The problem described original post, way at the very top, I cannot reproduce here in the latest - are you seeing the same problem as described there? If not, can you describe exactly what is going wrong and if possible, post an example file(s)



I have a very manual workaround. when this happens — isolate block , normally some kind of copy paste first… , explode, selblock explode, sel block explode … going to layer sel objects on layer… finding culprit. changing layer… making nice. PURGE… reblock. reblock. save. reorient. something like that. sometimes I do not want to reorient so I just block edit and keep going into the blocks and selecting objects on that layer until I finally am able to select the objects because I have finally located them… and then I just change out that layer where I want. so I can rid that layer purge it. save block…

I had this same problem of ghost layers. I removed a bunch of linked and embedded blocks from a large file, and ran purge several times, but the layers remained. Like others have described here, I saved the file then reopened and the layers went away. The problem is resolved, but I just wanted to follow along… would love to know why this happens/how to prevent it. Thanks!!

Hi Andrew - there is no way to prevent this.
The issue was logged as item RH-29498 and I’ve added this thread to the report.

1 Like

Well, I just opened an old file of mine in Rhino 7 and discovered a whole bunch of reference layers in it, very similar to what’s been screenshotted above.

I have a script from this site that moves all block definitions to a layer, and when I try to run it on what I suspect are the offending objects, I get the following:


So, time for me to ask the now 4 year old question, how do I get rid of these “reference layers” (and when will we get an improved object/block manager)? :stuck_out_tongue:

Robert -

Does that mean that saving, closing, and reopening the file doesn’t make those go away?
FWIW, as you can see, RH-29498 is still open…

Added a file to the post. Please try to open it and let me know what you see.

EDIT: Deleted the file because it turns out that the blocks were directly linked to a Solidworks file! Holy shit, I didn’t even realize you could do that, and how did past me manage to do that anyway? :sweat_smile: