Can't delete a linked file


I’ve linked (referenced) a file that has vegetation and want to delete it. To my knowledge there are no blocks preventing me from unloading it, but I am still getting this error. See screenshot. I can’t select the link, it is not locked so I’m not sure what is happening. I just want to delete it/unload it, why does this process seem to be so restrictive? What am I missing?

Thank you!

Can you select instances using SelBlockInstanceNamed ?

I get “No objects added to selection”

Did you include the instance name “vegetation”?

Yeah. I also changed it’s properties from Linked to Embedded and linked. That didn’t do anything. I tried going to Rhino 6 since the file was created in Rhino 6 and I’m working in Rhino 7. That didn’t do anything either. I don’t want to copy everything into a new file and start from scratch because this seems like it shouldn’t be so difficult. Is this a known bug of sorts?

Hello - see the Purge command - that will let you remove unused block definitions.


I tried this. I’m getting the same error