Can't cut nor cap this extrusion

For some reason I can’t cap or cut the vertical extrusion, and I have no idea why (picture shows how the surface buckles). To me it looks like I extruded from a clean curve etc, but the resulting surface wants to go bananas when trying to cut or cap it.

extrude-cut-fail.3dm (227.7 KB)

// Rolf

Hi Rolf,

You should probably rework that extrusion so it’s not buckled.

Regardless, cap doesn’t work on non-planar openings unless you use some plugin or special component, but maybe trim the green part away first then join the fragment to the extrusion and then cap?


When I extrude the surface from the curve, the extruded surface seems ok. It is after trying to Cap or Cut the extrusion which makes the extruded surface become buckled.

// Rolf

sorry didn’t mean to delete the reply - you’re right it fails even with lofting instead of extruding

but if you rebuild the curve (or use a new one) it seems to knock out the bug:

If you split the extrusion in both ends, everything works well. I think that the problem is the amount of curvature for a degree 1 surface.

1 Like

To me it looks like a bug, but perhaps I’m wrong.

I tried to make the extrusion with a Sweep2 surface instead, and that worked.

In any case, thank you guys for your help. I can proceed now.

// Rolf

The red curve is unusual. It is degree 3 but has discontinuous curvature, presumable because it has multiknots. Explode it and two degree 3 curves result; one curve with a long segment and the two ends, and the other a long segment only. The long segment and two ends has discontinuous curvature with the multiknots. RemoveMultiknots drastically changes the shape of the curve.

How was the red curve created?

The red curve was drawn from top view as a Control Point Curve. However, one curve end turned out to not being located on the plane (it was sligtly above) so I projected the curve down to the plane (and probably ran FitCrv on it as well). Perhaps that could explain why it causes surfaces going bananas.

// Rolf

I opened the model and it looks like a typical rendering mesh failure that Rhino has since many years. Recently I mentioned this to Pascal. This happens on surfaces with Degree 1. There are two simple solutions, depending what you are looking for:

  1. If you select the model, open the Properties window and apply a custom mesh with “Minimum aspect ratio” like 6 or so, the problem with wrong rendering disappears.

  2. To completely get rid of this problem without using a custom render mesh, you simply have to use the “Merge surfaces” command with the “Smooth=No” and “Roundness=1” options. Then both surfaces will be transformed into one that you can cap and it will not have any issues with the rendering mesh.



1 Like

True I actually projected to Cplane before rebuilding the curve (redundant step) and it worked - I have faced similar planarity issues in the past: