Can't control rotation of lofted profiles in Grasshoper

Hi Guys

I’m trying to make these profiles from the ceiling to the ground like this:

But I’m experiencing an unwanted rotation at the base XY where the profiles start from the ground like this:

I’m uploading also the working file if someone can help me to fix this issue. Thank you in advance!

wave_profiles Modified SU (1).gh (29.7 KB) wave_profiles.3dm (4.3 MB)

The loft has rotated at the two ends because you’ve isolated the sections at the ends, rotated them, and then lofted. If you don’t want this rotation then why have you rotated the sections? If you just want the sections moved to those locations without the rotation the do just that:

Hi

Thank you for your response! Were can I find the List item with Item (i), Item -1, and Item +2?

if you zoom-in on the component you will see + appearing, clicking them will add more outputs

1 Like

I tried this option but I don’t understand why the loft its not happening…

wave_profiles Modified SU (2).gh (35.5 KB) wave_profiles.3dm (4.2 MB)

It’s not happening because you’re working on the exploded rectangle (4 lines) rather than the closed rectangle (1 curve):

it should be this:

Also the same logic to manipulate the lower curve wont work on the upper end curve so you;ll need ot figure out what you need to do to that one to get it in the right place.

It now looks like this:

Also, not quite sure what it is you’re trying to achieve, but can you not just sweep rather than lofting? Much simpler (depending on your desired output). IMO you’d be better of sweeping and controlling the ends of the volume by controlling the sweep curve rather than manipulating a list of sections to loft between

Hi again! Thank you for your suggestion! I’m trying to create these profiles through a tutorial I found online. For me it would work if the profiles are sweeped, I tried to make apply the suggestion you mentioned above but I can’t execute it!

Can you please help me one more time? Thank you in advance!

wave_profiles Modified SU (2).gh (32.4 KB) wave_profiles.3dm (4.3 MB)

Your PFrames component isn’t working, so check what the error message says. I guess you haven’t set a curve parameter for it to take the frame at yet. Set t to 0 and it will give you a frame at the start point of the curve:

image

1 Like

It’s working perfectly now! Thank you!

Although in this way if I try to play with the graph mapper I can’t align the top rectangle with the vertical ceiling and the profiles that are produced are not moving like a wave randomly but they follow the first curve like this:

In my previous attempts, I made it to create the profiles that were using the graph mapper to have a wave effect on the profiles but I was unable to align the bottom profiles with XZ and a ZY curve and the top profiles with the ZY plane and the top ZY curve like this:

wave_profiles Modified SU (2).gh (31.9 KB) wave_profiles.3dm (4.3 MB)