Cannot set tolerance for fractional inch dimensions without a fiddle

If you try to set the tolerance fields in an annotation style or dimension where the Unit - Format is set to Inches - fractional you find that the fields are locked.

To change the tolerance values you have to change the Unit - Format to Inches - decimal, move the focus from the settings panel and re-enter it. Then you can set the tolerance values before changing the units back to Inches - Fractional.

Rhino 7.21.22208.13001, 2022-07-27