Cannot select existing surface in file

I am working on modeling the AUdi R8 and have a roof surface that was created earlier. I have refined and modifed the curves that are part of the curve network used to create the surface. I have tried many times to select the surface to delete it but it will not respond to selection. Any suggestions?
Here is a picture of the Audi roof with the newly refined surface in gold and the existing unselectable surface poking through in green.

Have you tried the Unlock command yet? It may have been locked at some point. Also make sure it’s not on a locked layer and that your selection filters aren’t a factor (SelectionFilter command).

Any luck? If not, post the file please or email to

Brian, thanks for your response, where would I find the locked or unlocked setting for a surface object?

Just type Lock if something you want locked is selected or Unlock to unlock any locked objects globally. Lock and Unlock are commands so you’ll have to press Enter as well.

Thanks that worked like a charm. I have one other issue that I would like help with I will open it in a new post. Thanks again for your assistance.