Cannot install on new computer


(Marc Gibeault) #1

@brian I think it’s you who could help me:
To run, the installer needs to get an administrative password. But then, it cannot acces the internet.
I get the message to click on the gear icon to click on “Download packages for offline installation” but there’s nothing like that on this window:


(Brian Gillespie) #2

HI Marc,

That’s weird. I’m not very good with French, but I think the thing to do is uninstall by clicking the Modifier button. After you do that, then running the installer again should give you the gear icon with the advanced options.


(Marc Gibeault) #3

I don’t have it installed yet…
And shouldn’t that be in English if I downloaded the English installer?


(Marc Gibeault) #4

That “Modifier” button will just change the installation folder.


(Marc Gibeault) #5

Something interesting:
If I “run as administrator” the installer (instead of waiting for the prompt to do so), I get an English dialog box and if I click on the gear icon I get this:

Clicking on “Install Now”, I get the “Download Failed” window and clicking on “Download packages for offline installation” does not work: I’m still an admin at that time and can’t access this kind of address.


(Brian Gillespie) #6

Can you please send me the error log that the installer generates?


(Marc Gibeault) #7

Sent to you by message…


#8

In my experience, the hot spot for clicking on “offline installation” is specifically on those words. Did you try to find it on the RH side of the sentence?


(Marc Gibeault) #9

As I said, I did. The link works but it’s blocked because I’m an admin at that time.


(Marc Gibeault) #11

I tried to start the installer on another computer and download the files there. It worked and I got this message:

What is meant by “run this installer to complete the installation” ?
I noticed that a new file named “Bootstrapper.exe” was created alongside the “redist” folder.
I copied both to my computer and run this Bootstrapper.exe. I got the same result:

I’ll sent you this install log by message.
I tried to run it both as administrator and as a normal user (and entering admin credentials when asked for) with the same result. It seems to still try to acces internet…


#12

You download and run the original installer by clicking on the “Download packages for offline installation”, which you did successfully. Now you have the original installer and the redist file on your internet connected machine. The next step is to move the original installer and the redist file to the machine you want to install Rhino on, putting them both in the same directory. Then run the original installer on the target machine and click the “Install Now” button instead of the “Download packages for offline installation” hotspot. This should do the installation. I don’t copy the bootstrap file to the target machine.

When I update I do the download as an ordinary user, including the redist download using the installer. After I get the files over to the target machine I run the installer as an administrator.

HTH.


(Marc Gibeault) #13

Still no luck… the installer stills tries to check the internet…


#14

Sorry to hear that. I got nuthin’ more. I hope Brian does.


(Marc Gibeault) #15

Yes he did!
The installer file was corrupted in some way (it was 171MB instead of 201MB).
It’s working now!