Cannot Delete Duplicate SubD Objects

I just got Rhino 7. I was working on this leaf design in SubD. I created part of one side and then reflected it. I finished the rest of it, zoomed out and discovered that I have two duplicate items to either side of the leaf in the center. I must have screwed up the Reflect command somehow. Now I can’t delete them. If I select any one object, they all become selected. And they won’t ungroup. So, I’m in a fix. Any ideas?

Hi Gene - can you select these at all? if so, run Reflect > RemoveExistingSymmetry. Does that free anything up?


Hi Pascal,
I can select them. I ran Reflect > RemoveExistingSymmetry but it didn’t work. But, I figured it out. I started the model on the left axis, then reflected to the right. When I tried to delete from left click select it didn’t work. It deleted everything. When I tried to delete the right hand object with SubD > select it didn’t work. But SubD select > Delete on the left hand object deleted both of the duplicate objects leaving the leaf intact. Nice. I was approaching it more like deleting mirrored NURBS objects.