Can we add constraints before meshing?

Hi there!

First of all, thank you for the sofware! I’m enjoying my ride learning Eto / IronPython a bit with it. Lately, I have come with a question that I don’t find a way to answer with my biased knowledge.

Say I want to mesh an specific face from a given solid and I want to specify certain points of its surfaces for the mesher to respect. By respecting these points I mean for the mesher to put there a vertex when meshing.

Is that even possible? Is there a way to specify certain constraints to the meshers?

Thank you in advance!


Hi Julio -

I’m not sure if this is a coding question or a modeling question.
In Rhino, the QuadRemesh command allows you to use guide curves. In Grasshopper, the TriRemesh component has a Features input.

Hi Wim!

Thanks for your reply. I have tried in multiple times to execute that option (QuadRemesh). I’m within the trial period the a message telling me that the command is not registered appears, [Versión 7 SR12
(7.12.21313.6341, 2021-11-09)]:


Strange as I can get the following script from your resources:

And I can remesh a cube:

Regarding code or modeling, first I want to try the UI and see if I can achieve my purpose before going into Python. Don’t know if that makes any sense to you. Hope it does.

On QuadRemesh options, I can see the Symmetric Axis thing as a possible way to solve the problem but I cannot check any options on the UI regarding that :S

Hello- can you see the QuadRemesh plug-in in Options > Plug-ins?


Also, I am playing with the script and reading the docs (QuadReMesh | Rhino 3-D modeling) but, after placing two guide lines, nothing happens no matter what GuidCurveInfluence integer I use on the script :S

You can see in the left cube two guide lines near to the top left corner.

Hi Pascal!

I can see the plugin in my option panel. Sorry for the spanish.

I think I would run a repair on the Rhino installation.


Hi again Pascal,

same result after perform the repair. Either way, it does not matter to me if I can call the QuadRemesh from scripting but the thing is that it seems not to be working (remeshing does not follow my direction :()

Hello - please run the _SystemInfo command in Rhino and Copy/Paste the results here.


Here it is:


Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Evaluación, revisión 2021-11-09
License details: Cloud Zoo
Expires on: 2022-02-07

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [91% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 5-5-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 7-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 471.41
> Integrated accelerated graphics device with 1 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-12-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\CodeListener (8c4235b6-64bc-4508-9166-bef8aa151085)\\Rhino 5.0\x64\CodeListener.rhp “CodeListener”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Hello- hmmm - I would at least test it without ‘code listener’ - disable that plugiin in Options > Plug-ins page then close Rhino and re open it - does the command work now?