Can’t do boolean difference


beehive chair.3dm (708.7 KB)
im not sure why i cant do the boolean difference here. the exclamation marks says Intersection curve ends at a naked edge. can someone help me with this. ive attarched the rhino file together

The 3dm file you’ve uploaded is not the same as the one shown in the video. The object(s) at the top are missing.

-Kevin

hi @Lashmeni_Ramaraju your objects are open polysurfaces, that’s why it fails probably:

That’s because you have open hexagonal surface extrusions, not closed solid pipes. Close the ends of the pipe walls and it should boolean difference fine.


(Shown using an alternative seat form as your file omits it.)

Edit: @Gijs beat me to it!

hi im sorry for my mistake. here’s the right file
BEEHIVE CHAIR.3dm (951.8 KB)

hi @Gijs i made a mistake uploading a wrong file. here’s the right one
BEEHIVE CHAIR.3dm (951.8 KB)

i’ve added an object to the top but still failed to do so

hi i’ve made a mistake uploading a wrong file. here’s the right one
BEEHIVE CHAIR.3dm (951.8 KB)

i’ve added an object to the top to close it but still failed to do the boolean difference

@Lashmeni_Ramaraju there is no need to reply to each and every person in the thread and put the model in many times… If you want you can do that by either quoting part of their reply or using @ mention.

There are many issues you need to solve to make this work:
The planar disk you added to the top of the pipes is useless. Delete it.
Run PlanarSrf and select all the top edges of the hexagon pipes.
Join the hexagon pipes with the created surfaces.
Select the hexagon pipes and Cap. Check that these pipes are now closed polysurfaces.

Create a single closed object from the surfaces that need to form the cutter. For this explode all the cutter surfaces and delete all those that are not relevant.

Scale1d the pipes so the fully intersect the cutter

Then the BooleanDifference will work.

Before working on the pipes to make them solid, you may want to look at a couple of positional issues where pipes touch or overlap, here:


If you don’t adjust these you will need to “solidify” them one by one and not en masse.

“En masse”? - you can use sub-object selection to select all the top edges in one go in the front viewport. Then when you use ‘surface from planar curves’ all the top surfaces will be created. Much quicker than selecting individual edges… To simplify selection, either isolate the hex tubes or move them to a different layer from the rest of the geometry and turn off the latter’s layer.

HTH
Jeremy