Can I hide the "Please Wait... Updating toolbars" splash?

Is it possible to hide this window, or prevent it from showing?

As far as I know, this only shows up once on the first execution after a new or update installation. Is this a serious issue?

In my case it is showing up on every startup (Rhino 6 WIP).

We also launch Rhino with a path to our plugin to make certain it gets loaded, and not sure if that is now a problem in Rhino 6 WIP.

@dale, @brian

Interesting. Did this behavior start with a new or update installation and then just keep happening, or did it just start happening with a version that you had been starting and using normally for a while? Which WIP release is giving you the problem? Does it happen if you start Rhino without your plugin or anything associated with it?

I only just yesterday converted our new application to Rhino 6 WIP. I’m not certain if every time or just recently it began this behavior today.

After testing I see that it happens when I launch Rhino by itself, and it also happens when I launch Rhino in Safe Mode.


I also deleted all of the Schemes in the Registry and let it regenerate the default scheme, and it had no effect.

Hi Jason - just a thought - try a right-click on the Rhino icon and Run As Administrator once - does that clear it up?


No it didn’t have any effect. After running as Admin, shutting down, and starting back up it still pops the dialog.

Hmmm - I guess it is unpacking a new toolbar every time - do you have the folder



Anything in there?


Yes. Should I empty it?

Nope. Looks like you’ve discovered a bug. I’ll see if I can figure out how to reproduce it.

Did you install the WIP in English or another language?

I installed the English version. I also installed the corresponding SDK if that helps narrow anything down.

Let me know if there is anything I can capture for you, logs, screens, etc.

Can you send me a screen shot of the contents of this registry key please:


My guess is that you do not have a value named “InstallDir” but you do have one named “InstallPath”.

If you make one called “InstallDir” and put the same path in it’s data as “InstallPath” this problem will go away. This is already fixed for the next WIP.

Looks like I already have that key and value.

The latest build has fixed this issue. Thank you!

1 Like

Having done deployment of Rhino to many machines that were then “frozen”, we saw this issue persistently on every machine on every launch. We’d tried a few things to get rid of it but something in the cleansing of the user profile during deployment forces Rhino to do this every time. I would ask on their (an Architecture school)'s behalf to have this reduced to a less intrusive popup if it’s no hassle.

This problem has been fixed in their latest WIP update.

@Alexander_Kaplan If the school is resetting the user’s profile on logout, then Rhino will always run the process of extracting its per-user resources. A couple of possibilities exist for solving this issue in the context of a school lab deployment, but I’d need to talk on the phone with you to understand the scenario exactly.

I’ll PM you next so we can connect via email or on the phone.