Can I change the name of a custom imported display mode?

I Installed a display mode that is not in the Latin alphabet. Is there a way to rename it. Opening the .ini shows a long character string that repeats and I think is the name. I tried expoerting as another name and then importing, but ot comes back in as the old name.

Yes.
In Options > View > Display Modes, select the one you want to change.
The name is at the top. Change it and click OK

Easy peasy

I had tried that. The existing name text cannot be deleted or overwritten. Here it is selected, but I can’t do anything else. Could the problem be because of the Cyrillic alphabet?

Maybe. I don’t have any Cyrillic display modes to fiddle with.
What happens if you select it, use the copy option, name that one, and delete the one you can’t rename?

I tried that. Named the export differently. When I imported I got the message that I already had the mode and should Rhino “overwrite.” I clicked yes. The import came in with the existing name not what I gave the .ini file. I did it a gain making sure to delete the mode before the import. Same result. The only thing I haven’t done is shut down Rhino before importing.

If you want to post the display mode INI file I’ll mess around with it and see what I can figure out.

Thanks. Here you go.
Чертеж 6.ini (13.9 KB)

I can’t rename it either, but I CAN rename a copy of it, then then delete the original.

  1. Import the display mode
  2. Select it and click the Copy button
  3. Rename the copy
  4. Delete the original import

Thanks. That worked.

Not sure why, but renaming works well on my Windows 10 and I can’t replicate the issue you had with my custom ini file. Sorry foe the inconvenience.
The “Чертеж 6.ini” name translates as “Drawing 6.ini” in English.