Can Anyone help me fix this issue?

My current machine is a macbook pro 2013/14 retina with a Geforce GT 650m
As you can see the blue surface did not fully “make surface” because of a curvature shape. The curve was made using the “fillet” tool.This comes out even when rendering and I need fix this before I output final renderings.

In the image, you can see the blue surface doesn’t fully surface the curve shape. Instead, it’s jagged. I went to options > mesh > and change from jagged & faster to smooth & slower, and although that helped a little bit, it still doesn’t surface out perfectly to its shape.

please help! this hinders my renderings!

This is my go to custom mesh settings. I’ve not found the smooth & slower setting to be much use.

nm im goign to give this a try. will report back. thanks!

wow that worked!

but now when i rotate (my model is quite large) it slows down!!

i guess i can change it to these options when i need to render…

You can assign this setting to specific objects in the objects properties dialogue. That should address your speed issue.

1 Like

thanks for your help!

checking individual objects worked really well, but what happens when an object doesn’t take on the custom settings?

Sorry, I have no idea what to do in that case. I honestly don’t understand why this would not work on some objects either.

Hello @vyan28, Mesh Settings should be adjusted to suit the scale of your model.
So the settings you used above have worked but are probably overkill for the scale of your model which is why viewport movement has slowed down so much.
Before you changed the setting you had too few meshes representing the geometry which is why you had those jagged corners, and now you probably have too many meshes representing the geometry onscreen.
For my needs I always setup a custom mesh for every project.
Many of the settings in the custom mesh take priority over others. ie. In each surface mesh situation whichever setting gives the smallest mesh in that situation eg. edge, corner etc. seems to dominate the mesh structure for that area.
So I’ve found that you actually don’t have to define every option in the mesh settings to the nth degree because you end up going in circles and working against yourself.
For my needs I get really smooth but ‘light’ meshes by doing the following:

  1. Set Density to 0.9
  2. Start by setting everything except the following items to 0 (default)
  3. Minimum Edge length:
    As it says this option dominates on edges so in the case of your corner piece which gets broken down into straight egdes or jumps you want this number to be small enough to ‘look’ like a curve at your normal preview or render distance, but not be excessive and overload the viewport with unnecessary meshes. So this depends heavily on the scale of your project and also how closely you will be viewing that scale in presentation etc.
    For my needs working on objects about 20m in length I find that a value of 1mm is fine here and works for closeup renders too.
  4. Maximum Edge Length:
    This applies if there are long straight edges then the mesh can simplify into large pieces limited to the size specified here. Experiment, but for me about 500-1000 (mm) works nicely here. I’m working in mm in my project so adapt your setting to the UNITs of your project. You could make this larger and end up with very simple meshing on square planar shapes but I prefer this size when it comes to adding displacement to the mesh and rendering in vray.
  5. Maximum Distance Edge to Surface:
    Same idea here with project and model sale. Figure out what would be a visually acceptable gap between 2 x adjacent objects or along an edge where 2 x surfaces or sub surfaces of a polysurface meet or touch at your normal viewing distance. For me anything up to about 1mm isn’t actually visible in view-port or renders, but if you’re doing a model of something much larger then perhaps a few mm for this option would not be noticed when zoomed out.
  6. Minimum Initial Quads: You can leave this on default of 0, but I prefer setting this to 4 sothat even a simple square planar surface at least has 4x divisions, which I think would translate into 8x triangular meshes.
  7. Tick all the lower options except Pack Textures.
    With the above settings set in proportion to your model and viewing scale I have found that the above settings then dominate over mesh creation and the options above them like angle etc. don’t actually play a part in mesh creation so you don’t have to worry about them as much, unless you really end up with certain subtle shapes not playing along or meshing badly,

These are just my hands on thoughts and what I have figured out from trial and error optimizing my meshes for viewport speed whilst maintaining rendering quality. Hope it helps. Good Luck. Michael VS