Camera-specific (?) antialiasing (?) issue

This issue has been driving me sort of nuts lately. I end up having to re-do details and it slows me down significantly.

I used to think it was just in viewports, and that it was a SectionTools issue. But it’s def not.

In fact, I was able to figure out that when the issue happens in model view, I can save the NamedCamera view (“antialiasing” in the image) , apply it to another viewport, and THAT viewport shows the same issue suddenly. And then if I go back to the original problem-viewport, and enact a different NamedCamera view (“non-anti” in image) the original problem viewport is suddenly fine again.

This is not display-type dependent, (though I’ve found in Details that only sometimes if I change to, saw, wireframe, and then back to my intended display type, all is well again.)

I don’t have a model I can share at the moment, as I’m not allowed by the company I’m working with, but I’ll post my SysInfo below.

Thanks in advance.


Rhino 7 SR8 2021-6-23 (Rhino 7, 7.8.21174.15001, Git hash:master @ f30806bf209be7547baaa5decc53b3dbc50946ff)
License type: Commercial, build 2021-06-23
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 8-5-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 471.68
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 8-5-2021 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 1-22-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-5-2021
Driver Version: 30.0.14.7168
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\LayoutManager (23664189-f095-4e9c-8f6d-1073c2c60efc)\0.2.6.0\LayoutManager.rhp “LayoutManager” 0.2.6.0
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.0\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.1.0.0
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.1\Substance.Win.rhp “SubstanceImporter” 2.0.1.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21174.15001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21174.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21174.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.8.21174.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21174.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21174.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\BlockEdit.rhp “BlockEdit” 7.8.21174.15001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 7\Plug-ins\NamedPositions.rhp “Named Position”
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Hello - my guess is you will find the camera coordinates to be very very large in the views that look incorrect.

-Pascal

Yes, that’s correct. I was trying to change them, but it’s for standard “Right” elevations, etc.

I was able to bring the camera in to a new file and re-create the issue. Attached. AntialiasingIssue_211014.3dm (130.8 KB)

And when I am able to change the location of the camera, the target location becomes huge in the negative direction, etc

Hello - turn on the camera points for that view (f6, or use the named view widget) and drag the camera point in X until it is a rasonable number, 500 or 1000 or so. In this case Gumbalkl is perfect. Your need to move it a long way (in top), Then resave the named view.
But, how does it get like this?
Incidenatlly, this has nothing to do with anti-aliasing, it is the shadows that are limited in the number of levels of gradtion they can show and when the camera is that far away, the gradations simply not enough to look right.

-Pascal

How DOES it get like this? Any clue?

How do I save “Right” view? Its not a NamedView. Would just moving the camera and saving the file as my new template work well enuf?

Hello- if you save any view, you can give it a name that makes sense.

-Pascal

Actually, I was asking how it got saved to the actual “World Right” view.

But (for those following this at some point) I imported my usual job template into a new Small, Inches - Feet-Inches Template, and saved that as my new job template, and it seems to be working.

Follow-up @pascal - Does it matter which kind of Rhino Template (small/large) I actually use for my base template? (i.e. should I be going back and forth between those two template styles if I’m modeling different-sized set pieces?)

Hello - small and large differ mostly in the absolute tolerance used - fatter by 10X for large objects.

-Pascal

1 Like