Camera movement is not fluent in the very begining

I noticed this a while back, but now since I use WIP more and more it gets annoying.

When rotating and panning at the very beginning, like half a second, the movement is not at all fluent, sometimes it first jumps into a new position and than it starts to run fluently. So if I make small camera movements all the time it jumps all the time. I notice the difference clearly between Rhino 5 in which thins work well, and the WIP.

Do you have a 3Dconnexxion mouse? If so, this behavior is due to the calculation of render meshes (even when you’re in wireframe view) because these meshes are used to calculate the position of rotation. You can disable “rotation center” and I think the problem then goes away.

No, I have a very banal mouse which is not a space mouse.

Strange, I just saved the file and things seemed to improve. Still, I copy-pasted the model in Rhino 5, and there is a difference, Rhino 5 is more fluent.

When the model is complex WIP behaves better than 5 but overall on a regular model Rhino 5 is more fluent.

Actually, I can confirm this! When the model is not saved the camera movements are not fluent.
To replicate, i open a file move the camera and things are OK. I take all the model and i copy-paste it in another WIP instance and the camera movements are slow.

It does sound like there are render meshes being created in the background.

Yeah, if I save small, it still happens.

Does this happens in any mode? Or only in Shaded, or Rendered?


It seemed related to the linked topic, that’s why I suggested render meshes and the role of the 3dConnexxion mouse.