C# problem - missing 'alink.dll'

Hey guys,
since a few days I’m having a problem with the missing link to the alink.dll with C# componants.

problem occures:
Rhino 6 64-bit and SafeMode
Rhino 5 64-bit

problem doesn’t occur:
Rhino 5 32-bit version and SafeMode

I reinstalled all .NET frameworks since the alink.dll is a part of it without any success. Even reinstalling or repairing Rhino 5 and Rhino 6 didn’t help!!!

Any Ideas on how to work this out?

Just to be sure, the alink.dll isn’t an unmanaged 32-bit dll is it?

What’s the exact location of the dll?

How to find the location of the alink.dll c# is using?

During the repair process of Rhino 6 the .NET 4.5 is repaired. Since GH is now a part of Rhino 6 the alink.dll should be replaced/repaired in case of damages or wrong -bit versions?
Is Rhino 6 using a new .NET version which I have installed and the repair of the damaged alink.dll in .NET 4.5 has no impact?

I don’t know what alink.dll is for, or who is responsible for making/distributing it.

Seems like it might be part of the compiler/linker, but that’s just based on a single comment I found online. @stevebaer @brian, do either of you know whether this dll could be affected by us installing a .NET framework? Do we even still do that in our own installer?

I just did a search on my system using Everything, and there appears to be none in my Rhino install (which is Rhino 5 Educational though):

1 Like

Nor do I.

@kaspar-ehrhardt can you please send the actual C# code in your component that is causing the error? Does it happen with empty components?

beside your four registration I have four more registration in .net 2.0 and .net 4.0 both in 32-bit & 64-bit versions. Having Rhino 5 and Rhino 6 installed:

I tried to repair the .net 4.0 with Microsoft .NET Repair Tool trough the Command Prompt without any success

empty C# componants do not return this problem. Even a simple A = x; causes the missing alink.dll problem on my computer … All not working C# componants work fine on other machines

@kaspar-ehrhardt on the machine it fails do you have Visual Studio installed? If you do you probably need to repair the installation. IIRC alink.dll is loaded with VS.

Yes I have. I reinstalled Visual Studio already

SOLVED: In the end I had to replace the alink.dll file in the following paths manually:

C:\Windows\Microsoft.NET\Framework64\v2.0.50727#
C:\Windows\Microsoft.NET\Framework64\v4.0.30319
C:\Windows\Microsoft.NET\Framework\v2.0.50727
C:\Windows\Microsoft.NET\Framework\v4.0.30319

C:\Windows\WinSxS\amd64_netfx-_vc_assembly_linker_dll_b03f5f7f11d50a3a_10.0.17134.1_none_ae451a826e19ea72
C:\Windows\WinSxS\amd64_netfx4-alink_dll_b03f5f7f11d50a3a_4.0.15671.0_none_54063fa3b50a7200
C:\Windows\WinSxS\x86_netfx-_vc_assembly_linker_dll_b03f5f7f11d50a3a_10.0.17134.1_none_f5f2515982961378
C:\Windows\WinSxS\x86_netfx4-alink_dll_b03f5f7f11d50a3a_4.0.15671.0_none_9bb3767ac9869b06

To replace the .dll manually you need Window’s “TrusteInstaller” rights to your system where this Link helps!

Neither of this options helped to fix the missing alink.dll :

  • Reinstall or repair Rhino
  • .NET Repair Tool
  • Uninstall or Repair Visual Studio
  • Reset Windows System !

@nathanletwory Visual Studio wasn’t the problem either since I uninstalled VS + reset Windows without any success

1 Like

Good to hear you have found a fix for this problem!