Bump maps not rendering in raytraced mode


#1

Hopefully this picture explains my problem: I’ve added a bump map to a material. The bumps show up fine in Rhino Render and Rendered viewport mode, but not in Raytraced.

Frustratingly, I’m having the exact same problem in V5 with Neon&Brazil.

Does anyone have any ideas what could be causing this?

I’ve tried normal maps instead of B/W height map, and in V5 I tried Brazil procedural textures. All did the same thing, though I could swear I got it to work briefly in V5 yesterday, but alas its not working today.

(I’ve also tried .tga and .jpg file types, as well as CPU and GPU processing)


(Nathan 'jesterKing' Letwory) #2

I will have a look soon

/Nathan


#3

Thanks Nathan,

I’ve tried this on my work computer and can’t reproduce the issue. So its just something about my home computer. Very weird.

Works fine on this PC:

I’ve used the same texture file, I copied it onto my USB hard drive, with the exact same path. Why would it work on this PC and not on my home one?

-Gavin


#4

OK, I’ve figured out how to reproduce this, and I’m not sure whether I’m doing it wrong, but there is definitely a disparity between Rendered and Raytraced mode with large objects. The reason it worked on my work PC this morning was because I just quickly drew a sphere which was small, around 30mm diameter, and the bump mapping works as expected. But with a large sphere, around 3 metres diameter, the Rendered viewport looks right, but the Raytraced doesn’t.

Weirdly, Neon does the same thing in V5.

30mm sphere, Raytraced:

30mm sphere, Rendered:

3000mm sphere, Rendered:

3000mm sphere, Raytraced:

Hmmm, this seems to be nature of bump mapping? Blender does the same thing. At least in Blender, there is a strength input on the bump node, so it can be corrected.

It still doesn’t explain why Rendered and Raytrace differ…


(Nathan 'jesterKing' Letwory) #5

A bit late but still:

if you want to get useful bump mapping on a 3000mm object you should change model units to meters instead.

There is unfortunately no good way to control strength yet, at least not through regular GUI.