Bump: Bug background printing from layout is tiled


#1

Continuing the discussion from BUG: printing Background on PDF from layout (V5SR5):

Just discovered this problem for the first time.
If I have a layout with a detail in rendered mode with background set to an image file. Printing to PDF (or any printer for that matter) causes the background image to be tiled.
The Layout displays correctly and the print preview also.

Now I’ve got to go and recreate 20 presentation pages in Illustrator. That’ll teach me not to check the first one.
If there’s a solution I’d love to hear it as it’s going to take me hours to recreate all this.

Thanks, Steve


#2

I showed this problem 1 year ago… But any reply or bug fix…

Mcneel Guys?


#3

Bump. Can you at least let me know if there is (or isn’t) a solution on the horizon in the near term.

thanks, Steve


#4

Not sure why this seems to be such an unpopular question at Mcneel. It’s been unanswered since Oct last year.

@pascal
Pascal, could you please take a look at this or send it on to the appropriate person.

Thanks, Steve


(Pascal Golay) #5

@stevebaer - can you add your 2 piasters worth on this?
I think this is http://mcneel.myjetbrains.com/youtrack/issue/RH-20508

thanks,

-Pascal


#6

We determined quite a while back(early V4) that using pictureframes printed more accurately than did background images. They also don’t seem to have the tiling problem. You can place them directly on your layout page or like, in the attached PDF, in model space with a viewport centered over it.

Jim
CHEESE CHARCUTERIE SUSHI CHEFS 6-26-2014 EXPERIMENTAL.pdf (799.2 KB)


#7

Thanks Jim,

That’s a good workaround. That will keep me out of trouble for now.
It’s not as convenient as the background image option though, so I think this issue still needs to be fixed.

I just noticed a strange issue with Jims method. If I have a detail view with a picture frame filling it and then place another detail view on top of that. the second detail will only be visible in print if it is in wireframe mode. With all other display modes the viewport with the picture frame prints in front. So if I want to have a rendered detail with a background image I’m back to compositing in PS or Illustrator again.

Steve


#8

Steve,

There is one more thing I didn’t mention. The detail views placed over the top of the pictureframe need to be locked. Then It works fine. I have 2 layers set up for these detail views, one for the pictureframe and one for the line drawings. Then, I have a button that toggles the detail layers locked/unlocked and the picureframe detail on/off.

It’s a pretty streamlined workaround, but looking back, it took some time to set up.

Jim


#9

Ahaaaaaa!! Wonderful!
Thanks Jim. that works perfectly. How on earth you worked out the layer locking I’ll never know, but I’m glad you did.

Thanks again, Steve