Built against a different major version of the Grasshopper SDK

I intend to run a plugin which was developed for Rhino V5, but carelessly I installed version 6 instead. Then, after uninstalling v6 and installing v5, I get two error messages when I call the Grasshopper command. Please see below:

Error message 1:
The RotaryFunctionModule Component Library was built against a different major version of the Grasshopper SDK.
Local SDK = 1.0.0.20
Referenced SDK = 7.2.21012.11001

Error message 2:
The StandardFunctionModule Component Library was built against a different major version of the Grasshopper SDK.
Local SDK = 1.0.0.20
Referenced SDK = 7.2.21012.11001

I imagine that it might be possible to amend this, but I have no clue regarding how to do it. If you would please give me some guidance. I am no developer by the way. Thank you very much in advance.


Hi -

These two error messages tell you that you need to be running Rhino 7 to be able to use those components.

There are a few exceptions, but, generally, plug-ins that are developed for Rhino 5 will run in Rhino 6 as well.
-wim

These messages say that this plugin was compiled over Rhino 7.2.21012.11001, so as @wim says, you need Rhino 7 to use it, or compile it for another version of Rhino if you have access to the source code.

I got a similar message but with two different Rhino 7 versions
Newer minor version of SDK

It says “newer minor version of SDK”.

Hi Olivier -

Yes, you need to be running 7.7 for that one. You can do that by changing the update frequency in the Rhino options.
-wim