Bugs? in Rhino 7/8WIP: GPU heating and no extrusion handle in SubD, WIP 8

Hi

I have a Thinkpad X1 Extreme laptop with 64GB RAM, I7 CPU and a Nvidia 3070 TI GPU. When I start Rhino 7/8 WIP the temperature of the GPU goes 10 C up just by having Rhino open. There is no rendering, no shading no modelling.
When I open Blender the GPU temperature reacts when rendering or shading models. Else the GPU temperature doesn’t rise. For me this seems to be some kind of (mis)use of the GPU that makes it compute something though it isn’t necessary because nothing is visible happening on the screen. The strange thing is that the GPU doesn’t seem to compute anything or allocate extra memory when Rhino is started. The temperature just goes up and the GPU-fan spins much faster.

I have no clue why this is happening.

Before Rhino is started:

After Rhino is started:

The other thing I have noticed is there is no extrusion handle for the gumbal in WIP 8 when using SubD-modeling. It’s simply just lacking from the gumbal. This must be a bug or what?

Regards

Hans Christian

Hi @Hans_Christian_Fürst thanks for reporting the bug, I will add this to the bug tracker
edit: seems this one is already on the list as RH-72210 Gumball extrude dot no longer appears on SubDs

regarding your issue, pls. type _SystemInfo in Rhino and post back the results,

thanks.

Hi Gijs de Zwart. Thanks for your reply. I tried to search for that gumbal bug but didn’t succeed in finding it before.

Regarding my specs here they are:

Rhino 7 SR25 2022-11-22 (Rhino 7, 7.25.22326.19001, Git hash:master @ 2a680490f96a04550d1f39158b859c4f7739d024)
License type: Commercial, build 2022-11-22
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [79% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 8-4-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Ti Laptop GPU (NVidia) Memory: 8GB, Driver date: 12-5-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 527.56
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-5-2022
Driver Version: 31.0.15.2756
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Best Regards

I also have a laptop with a a Nvidia 3070 TI GPU which behaves similarly. When I start Rhino 7 but do nothing in Rhino the GPU temperature initially goes up by about 5 degrees, and then reaches an increase of 10 degrees. This is both the overall GPU and “Hot Spot” temperatures as reported by HWMonitor.

Rhino 7 SR26 2022-12-14 (Rhino 7, 7.26.22348.01001, Git hash:master @ 75d9704e78c487d6212f0a30cb275f20f791885c)
License type: Commercial, build 2022-12-14
License details: Cloud Zoo

Windows 11 (10.0.22000 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [79% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 11-3-2021 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Ti Laptop GPU (NVidia) Memory: 8GB, Driver date: 11-13-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 526.98
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-13-2022
Driver Version: 31.0.15.2698
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.26.22348.1001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.26.22348.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.26.22348.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.26.22348.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.26.22348.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi David,

Interesting to hear that others with same specs are experiencing the same issue.

Actually I tried to change the viewport rendering in preferences from GPU to CPU and that made no difference. The GPU was just as affected as before.

Regards

To me this behavior is interesting but generally irrelevant. I’m not aware of any adverse consequences though I usually do not have Rhino open without the system plugged in.

What do you mean by “without the system plugged in”?

I think this behavior is relevant because it uses unnecessary GPU-ressources and burdens the GPU. It won’t last longer because of this behavior.

Ok now I’m positive that this is a Rhino problem. I spoke with a chat supporter from Nvidia that checked the GPU-log and couldn’t find anything wrong with the card. I had to install a very handy utility called GPU-Z which has a lot of information about the GPU besides the temperature.

I compared Rhino to Blender and from what I could see Rhino is handling the GPU as if Rhino needed full ressources from it all the time.

In the moment I open Rhino the clock and memory allocation goes from 210 Mhz and 101 Mhz to 1000 and 1600 where it stays.

In Blender when ever using the Viewport to orbit or model or change something the clock speed rises a bit depending on what you are doing but in the moment you release the mouse and stop viewing and changing things the clock speed goes back to 210 Mhz and 101 Mhz as you would expect since the GPU should ony be called and ressources allocated when there’s need for it.

Im positive that this must be a Rhino bug.

Plugged into an outlet, also known as “mains”, so that the battery is not being used.

I no longer am seeing the increase in temperature when starting Rhino. No idea what changed.

Ah ok - That was what I thought.

Hm strange but good for you.

Hi Hans - a couple of things to check -

  1. Are you using a custom startup template? If so, does the problem go away if you assign no template at start up?

  2. When you open Rhino and you see the temperature and GPU usage go up, can you you please open Windows task manager, find the Rhino process in the list, right click and choose ‘Create dump file’ The file will be enormous. Please zip and upload to Rhino - Upload to Support to my attention.

-Pascal

Hi Pascal,

  1. No I’m using no template. The heating begins in the moment Rhino executes - even before you get to choose template or no template.

  2. Thanks a lot. I have uploaded the dump-file. Got it down to about 500MB.

Best Regards

Hi Hans - thanks, we got the file, I’ve let the developer know.

-Pascal

Hi Pascal,

Thanks a lot for your help!

Best Regards

Hans

@Hans_Christian_Fürst according to our dev Rhino is not doing anything, it’s just sitting idle. The dump doesn’t show any activity from Rhino’s side whatsoever.

Ok. Do you want me to record a video of the incident af upload it so you can see for yourself?

Hi -
When you start Rhino in Safe Mode, do you see the same thing happening?
-wim

… also,

This is on Windows, correct?
When you launch Rhino and see the viewports appear, a template has been loaded - even if nothing is specified in the options.
In your Rhino Options -> Files settings, what does it say for default template?
-wim

There is no one. It’s empty. I always choose no template:

The exact same thing happens.